ASSERTION: Received "nonqueued" message 295 during a synchronous IPC message for window 3868878 ("MozillaWindowClass"), sending it to DefWindowProc instead of the normal window procedure

REOPENED
Unassigned

Status

()

P3
normal
REOPENED
9 years ago
2 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86
Windows 7
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 429124 [details]
testcase

I'm seeing this assertion with the testcase in a debug build with oopp plugins enabled.
(Reporter)

Comment 1

9 years ago
Created attachment 429125 [details]
stacktrace of assertion

Comment 2

9 years ago
I'm assuming that Core:Plug-ins is a better fit for this.
Component: IPC → Plug-ins
QA Contact: ipc → plugins
Nope, this is in IPC glue code.
Component: Plug-ins → IPC
QA Contact: plugins → ipc
(Reporter)

Comment 4

9 years ago
Fwiw, I think this is also the cause of the plugin crashes that I saw with a particular testcase. (the crashing UI is really weird for plugin crashes. Also it seems like plugin crashes are always throttled)

Comment 5

9 years ago
#define WM_CHANGEUISTATE                0x0127
#define WM_UPDATEUISTATE                0x0128
#define WM_QUERYUISTATE                 0x0129

Updated

9 years ago
Assignee: nobody → jmathies

Updated

5 years ago
Assignee: jmathies → nobody

Updated

5 years ago
Priority: -- → P3

Updated

4 years ago
Blocks: 1052362
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.