Loading PKCS#11 module fails




Security: PSM
8 years ago
8 years ago


(Reporter: Darko, Unassigned)


1.9.2 Branch
Mac OS X

Firefox Tracking Flags

(Not tracked)




8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

PKCS#11 module, which works fine on other platforms (Windows XP, Linux) loaded as .dll or .so file, can not be loaded on Mac OS X. Alert message appears. The same problem appears in bug 496013, and it seems not be fixed on newer versions.

Reproducible: Always

Module has been successfully built and tested on Win XP, Linux and Mac OS X 10.6, successfully loaded on WinXP and Linux.
That's odd.  Bug 496013 claims to be fixed in Firefox 3.6...
Darko, which module are you trying to use? It sounds like you have a self-build module. If that is the case can you please attach it to the bug report? Further it would be nice to see exact steps you are using to reproduce this issue.

Comment 3

8 years ago
Yes, it's self-built module, but, unfortunately, I have no rights to attach it. I've also tried to load a file "libnssckbi.dylib", actually, I've repeated scenario described in bug 496013 and same alert message "Unable to add module!" appears. When I try to load libnssckbi.so, on Linux, I get message "Security Module already exists", so I suppose, the same message should appear no Mac OS X too, but it doesn't!
Also, I've tried to debug and see whether firefox call some of module functions, but, it doesn't.
Thank you in advance for your help!
Everyone should have permissions to attach files on a bug.

Can you tell us in which folder the PKCS#11 module is located?
Version: unspecified → 1.9.2 Branch

Comment 5

8 years ago

Comment 6

8 years ago

I can confirm that problem still exists in debug version of the trunk (Minefield) as well.

I've found out a possible temporary workaround:

After building the nss 3.12.5 from mac ports, I was able to manually add the module by using modutil.

After starting the firefox again, the module did show up. The functionality further test will be made tomorrow.

Best regards,
Honza, I'm absolutely sure that this was definitely ok, when I have verified the fix on bug 496013. Now when trying to verify it again with the same Shiretoko build it doesn't work. Do we suffer from an Apple bug?
Ever confirmed: true

Comment 8

8 years ago

Our module was built using CMake. We've used the Unix Makefiles generator. We've tried with XCode as well and failed. After trying to attach to the Firefox process, Xcode has reported that the build target was incompatible with i386 and ppc binaries. We have discovered that we have built the 64-bit module!!! :(

We've rebuilt it as i386, and everything worked!

Sorry for the false alarm, and thank you for the fast reaction.

Best regards,
Momcilo Majic
Darko: is this problem related to just a single module of your own, or any module you are trying to import?

There has been no activity on this bug for a long time, is this still valid?

Henrik: did you try to find a regression range or at least the same build it used to work to figure out it is some change in the Mac OS?

Comment 10

8 years ago
As Momcilo said, we have built incompatible 64-bit module instead 32-bit one and that solved problem. Problem was related to our module and libnssckbi.dylib module, but now both of them work fine.
Best regards,
Darko Nesovic
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 11

8 years ago
My first sentence is little obscure, sorry. Building 32-bit module solved problem.

Best regards,
Checked again with libnssckbi.dylib and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv: Gecko/20100513 Namoroka/3.6.5pre ID:20100513033551

Everything is loaded fine. Honza, shall we use this bug for the 64 bit module issue or is it known that we do not support 64 bit modules yet? If it's the latter case do we already have an implementation bug?
Resolution: FIXED → ---

Comment 13

8 years ago
We have tested the 64-bit modules under Ubuntu 9.10 (amd64) vanilla installation, and everything works correctly. I am not sure about Mac OS X, since only 32 bit binaries are provided.

That would make sense. We have 64 bit builds for 3.7a. Would be great if you could give it a test:


Comment 15

8 years ago
So, Darko's issue is fixed, and we should probably close this bug as NOTABUG.

Henrik, what's the other issue that you want tested?


8 years ago
Assignee: kaie → nobody
(In reply to comment #15)

> Henrik, what's the other issue that you want tested?

Thanks for the reminder. I have re-tested and everything works fine. So we really should close this bug.

Darko, can you file a new bug for updating the error message? It's really confusing on OS X. Thanks.
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.