Closed Bug 548927 Opened 11 years ago Closed 10 years ago

Greasemonkey causes Firefox not to start

Categories

(Firefox :: Extension Compatibility, defect)

3.6 Branch
x86
Linux
defect
Not set
blocker

Tracking

()

RESOLVED DUPLICATE of bug 551152

People

(Reporter: madcap, Unassigned)

Details

(Keywords: crash)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I'm running in Red Hat Enterprise Linux 5.3.0.3. 

Ever since upgrading to Firefox 3.6, when Greasemonkey is installed and enabled in my profile, and I exit Firefox (either from a crash or a clean exit), subsequent attempt to start Firefox in that profile result in Firefox simply exiting out (if there are any error messages from firefox-bin, they are suppressed by the firefox start script).

I can run Firefox in that profile again if I find the greasemonkey extension folder in my profile folder and move it. I can move it outside of extensions, restart Firefox into the same profile, exit Firefox, move the greasemonkey folder back into extensions, and then restart Firefox again and it will work... though I'll have to repeat the whole process again the next time Firefox exits.

I haven't had this happen to me in Mac OS X, but I have seen reports of this happening to other people in Linux (for example, see http://groups.google.com/group/greasemonkey-users/browse_thread/thread/8b3863f3a3362b00).

I'd tried it on a newly-created profile and it has the same results.

Reproducible: Always

Steps to Reproduce:
1. Install and enable the greasemonkey extension (as of this writing, latest is 0.8.20100211.5).
2. Exit Firefox.
3. Try to restart Firefox into the same profile.
4. ???
5. Profit.
Actual Results:  
Firefox will crash when trying to restart into the profile. I don't get a crash dialog or anything, firefox/firefox-bin just dies.

Expected Results:  
Firefox doesn't crash. ;-)

This only started happening when I upgraded to 3.6. I'll be downgrading to 3.5.8 and hopefully it won't happen anymore.
Okay, I just downgraded to 3.5.8 and, as expected, was able to start up into my existing profile (which has greasemonkey enabled, and was previously causing 3.6 to crash) without any problem.
I can confirm this with firefox 3.6.3 on Ubuntu 8.04.3, installed via ubuntuzilla, the symptoms are exactly as described by the OP. I tried to modify the firefox startup script to give me any usable information but without any success.

What can I do on my system to help debugging this, what actions need to be done to produce useful debug information? I will do it!

BTW: The very same problem with the very same symptoms also happens with the stylish extenion.
Is anyone "in the know" looking at this? This is still happening (tested with the latest version of firefox [3.6.3] and greasemonkey [0.8.20100408.6]), and it's still blocking me from upgrading to 3.6.


Ryan, indeed... it is a dup of 548927... that's this bug! ;)
Severity: critical → blocker
Component: General → Extension Compatibility
Keywords: crash
Version: unspecified → 3.6 Branch
QA Contact: general → extension.compatibility
(In reply to comment #4)
> Is anyone "in the know" looking at this?

No:

> Assigned To:       Nobody; OK to take it and work on it
This is a dupe of 551152
Well, technically, 551152 is a dup of this, since I entered this one earlier, but I can confirm that the bug described in 551152 does seem to be the cause of this. My system had a symlink for the parent of my home directory. When I changed that to use a bind mount instead of a symlink, the problem with Greasemonkey is no longer reproducible.

Thus, I'm going to officially mark this as a duplicate of 551152, since that bug is more specific and remedies are being discussed there.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 551152
You need to log in before you can comment on or make changes to this bug.