Last Comment Bug 548945 - Firefox 3.6 hangs on exit, possibly due to Norton IPS or Norton Toolbar extension
: Firefox 3.6 hangs on exit, possibly due to Norton IPS or Norton Toolbar exten...
Status: RESOLVED WONTFIX
: common-issue+
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-26 14:14 PST by Matthew Middleton (:zzxc)
Modified: 2013-07-11 17:56 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Extensions reported by Live Chat users with Firefox hanging on exit (2.06 KB, text/plain)
2010-03-03 10:57 PST, Matthew Middleton (:zzxc)
no flags Details

Description Matthew Middleton (:zzxc) 2010-02-26 14:14:23 PST
There have been many users reporting that Firefox has been hanging on exit this week in Live Chat.  Several users have confirmed that the problem is fixed by first ending the hung firefox.exe process, then disabling the Norton IPS and Norton Toolbar extensions.

Live Chat logs from this month with this issue are at http://10.2.74.133/cgi-bin/zzxc/chatquery.php?start=20100201&tags=wontstart|hang
Comment 1 Noah (oldtimer) [:Noah] 2010-02-27 13:57:45 PST
I also solved a hanging issue with a user in #firefox @ irc.mozilla.org, where his Skype 4.0 software was hanging Firefox on exit. He had no Skype extensions installed in Firefox, yet Skype was still interfering somehow.

I asked him to update to Skype 4.1 and that fixed the hang for him.
Comment 2 [:Cww] 2010-03-01 10:27:52 PST
Throwing this at QA -- can we get this looked at?  (We'd like reliable STR so we can write a KB article.)
Comment 3 Matthew Middleton (:zzxc) 2010-03-03 10:57:59 PST
Created attachment 430100 [details]
Extensions reported by Live Chat users with Firefox hanging on exit

I extracted lists of extensions from last month's Live Chat logs where hanging on exit was confirmed.  Norton Toolbar and/or Yahoo Toolbar is present in the majority of these cases.

In most cases of these, users fixed the issues by using Safe Mode to disable all extensions.  In a few chats, users confirmed that the hanging stopped after disabling only Norton Toolbar and Norton IPS.
Comment 4 Carsten Book [:Tomcat] - PTO-back Sept 4th 2010-03-04 15:18:45 PST
Hi,

after talking with a lot of people at CeBIT it seems that this could also by caused by Avira's Antivir.

Kev is reaching out to Avira and will do this also and will go to the CeBIT booth.
Comment 5 Carsten Book [:Tomcat] - PTO-back Sept 4th 2010-03-05 15:52:29 PST
talked to Avira at CeBIt today and they will inform their development to look into this issue
Comment 6 Wayne Mery (:wsmwk, NI for questions) 2012-06-15 13:04:50 PDT
(In reply to Carsten Book [:Tomcat] from comment #5)
> talked to Avira at CeBIt today and they will inform their development to
> look into this issue

Is this, and bug 535345 still needed?
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-07-11 17:56:53 PDT
Closing this old bug due to lack of progress. Please report a new bug if this is reproducible in a modern Firefox version with the latest Norton toolbar.

Note You need to log in before you can comment on or make changes to this bug.