Overly bold link on bugzilla bug report pages

RESOLVED FIXED in Bugzilla 3.4

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: u88484, Assigned: guy.pyrzak)

Tracking

unspecified
Bugzilla 3.4
x86_64
Windows 7
Bug Flags:
approval +
approval3.6 +
approval3.4 +

Details

Attachments

(4 attachments)

(Reporter)

Description

9 years ago
Posted image Screenshot
Overly bold link on bugzilla bug report pages near the top left of the page in the bug report.
John and Johnathan have a better eye for these things. But it seems like it's just choosing the completely wrong font, not doing so for me though. What system locale is this? It might be relevant.
(Reporter)

Comment 2

9 years ago
Pretty much every single font on every page I visit looks different.  Every font is either more bold or appears thinner.

Windows 7 (en-us)
NVIDIA GeForce 7150M / nForce 630M
Drivers: 7.15.11.7967
Kurt, could you investigate this a little more?  It's not clear from the screenshot what problem you're seeing, I'm not sure exactly what you're describing here.  If possible, could you attach a reduced testcase that shows the problem on your machine or at least a precise description of what text you feel is  too bold.  

On a generic Windows 7 install, bugzilla report pages appear fine.
(Reporter)

Comment 4

9 years ago
Hmm, the fonts look perfect on a new profile.

From the screenshot, compare the two bug numbers.  The "BUG 527707" on the left is bold compared to the "BUG 548969".  I know I used two different bugs but even on the same bug pages the same thing happens.  Just don't want you thinking that it maybe different because of the longer bug summary and expanded gray background for the bug page on the right.
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Hmm, the fonts look perfect on a new profile.

Ignore this.  I forgot to enabled d2d.
(Reporter)

Comment 6

9 years ago
Posted file Reduced testcase
So the bug with the font-weight: bold of the Arial font family.  The code     font-size: 175%; is not actually need in the test case and is only there to make it easier to see that the font is a lot more bold in the firefox version that has direct2D enabled (browser on the left).
(Reporter)

Comment 7

9 years ago
John, correct me if I'm wrong, I'm no font expert, but it seems like DirectWrite is choosing the Arial Black font-face for the requested display size rather than the plain Arial one (probably since DirectWrite realizes this is part of the Arial font family). I'm guessing that DWrite believes the font weight of Arial Black is closer to the requested font weight(not sure what weight we request when asking for Bold) than that of Arial Bold.
This correct rendering, it's caused by the markup which is requesting a font that's bolder than the bold face of Arial.  The testcase is equivalent to the markup below:

<div class="style: font-family: Arial; font-weight: bold;">
  <b>Bug 548975 - This is very bold with Direct2D enabled</b>
</div>

The <b> tag is has 'font-weight: bolder'.  Basic font families in GDI consist of plain, italic, bold, bold italic font faces.  But DirectWrite allows for a full set of weights and widths.  In this case, Arial Black is included in the Arial family so there is a font face that is bolder than the bold face when DirectWrite is used but not when GDI is used.

The page can be fixed with:

  b { font-weight: bold; }

I think this should be resolved invalid.
(Reporter)

Comment 10

9 years ago
(In reply to comment #9)
> I think this should be resolved invalid.
If so, this should be reclassified as a bugzilla bug then and left open.

Any clue if this is a common coding style?

Updated

9 years ago
Assignee: nobody → ui
Component: Graphics → User Interface
Keywords: regression
Product: Core → Bugzilla
QA Contact: thebes → default-qa
Version: Trunk → unspecified
(In reply to comment #10)
 
> Any clue if this is a common coding style?

Unfortunately authors probably don't distinguish use of 'bold' and 'bolder' because on Windows they've effectively been the same.  The same behavior will happen on other platforms (e.g. Mac) if the author specifies a family with more than just plain/bold weights.
(Assignee)

Comment 12

9 years ago
Posted patch v1Splinter Review
(Assignee)

Comment 13

9 years ago
Comment on attachment 429491 [details] [diff] [review]
v1

I guess this fixes the bug.. Not sure what the negative repercussions of this are
Attachment #429491 - Flags: review?(mkanat)
(In reply to comment #13)
> (From update of attachment 429491 [details] [diff] [review])
> I guess this fixes the bug.. Not sure what the negative repercussions of this
> are

Unless you're using a font family somewhere such as "Helvetica Neue" under OS X, you're probably fine.  Families with heavy weight faces like this are relatively rare, Arial just happens to be one of them because of the way "Arial Black" was handled historically.
(Reporter)

Comment 15

9 years ago
John, what should I do about other sites?  File an individual tech evangelism bug for each site?

For instance: the gmail archive button and at https://secure.ally.com/allyWebClient/login.do the menu items on the left column.  I believe I have seen this elsewhere today but it is kind of hard to pick out on sites that are using smaller fonts.
Comment on attachment 429491 [details] [diff] [review]
v1

Yeah, for sure. Don't know why we had bolder there.
Attachment #429491 - Flags: review?(mkanat) → review+

Updated

9 years ago
Assignee: ui → guy.pyrzak
Status: NEW → ASSIGNED
Flags: approval3.6+
Flags: approval3.4+
Flags: approval+
Target Milestone: --- → Bugzilla 3.4
Turns out not to be linked to D2D.
No longer blocks: 527707
(In reply to comment #17)
> Turns out not to be linked to D2D.

It's not related to D2D but it *is* an artifact of using DirectWrite, which is grouping font families slightly differently from the way GDI does.
(Reporter)

Comment 19

9 years ago
Is there nothing that can be done to fix this for every site that displays this problem?  I see the issue on almost every site.
Since this got converted into a Bugzilla bug, how about filing a new bug for the other issues?
(Reporter)

Comment 21

9 years ago
(In reply to comment #20)
> Since this got converted into a Bugzilla bug, how about filing a new bug for
> the other issues?

Filed Bug 550128
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/
modified skins/standard/global.css
Committed revision 7092.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.6/
modified skins/standard/global.css
Committed revision 7054.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.4/
modified skins/standard/global.css
Committed revision 6754.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 23

9 years ago
Verified fixed
Status: RESOLVED → VERIFIED
(Reporter)

Comment 24

9 years ago
Sorry, when I "verified" this, I had d2d disabled.  This is in fact not fixed on the bugzilla release currently used by mozilla.  Will the fix be included in the next update?
Status: VERIFIED → RESOLVED
Last Resolved: 9 years ago9 years ago
You need to log in before you can comment on or make changes to this bug.