animated GIF doesn't animate with D2D backend

RESOLVED FIXED

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: shaver, Assigned: bas.schouten)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta1+)

Details

(URL)

Attachments

(1 attachment)

Comment hidden (empty)
And by comment #0, I mean "it works fine with direct2d disabled, and in 3.6!"
(Assignee)

Comment 2

9 years ago
(In reply to comment #1)
> And by comment #0, I mean "it works fine with direct2d disabled, and in 3.6!"

I did test some GIFs, I suspect I know what causes this, and why my method of testing was actually flawed. This is properly some place in imgFrame or imgContainer where we're still not properly flushing and markdirtying surfaces, meaning our assessment that doing it on LockImageData and UnlockImageData was sufficient is false. I think I know what to do about this. Reopening the original flush/markdirty bug.
Depends on: 534787

Comment 3

9 years ago
WFM,
Windows 7
NVIDIA GeForce 7150M / nForce 630M
Drivers: 7.15.11.7967
(Assignee)

Comment 4

9 years ago
Created attachment 429373 [details]
Broken GIFs in D2D

The reason this might seem to work for people is because they load the GIF directly (which *sigh* is exactly what I did in my testing of animated GIFs).

As soon as a GIF is drawn in the context of a page different codepaths are used. See attached file, this should be broken on any D2D build.
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
(Assignee)

Comment 5

9 years ago
Fixed with fixing of bug 534787.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.