Browser is crashing while printing the mails

VERIFIED DUPLICATE of bug 54194

Status

()

Core
Printing: Output
P3
critical
VERIFIED DUPLICATE of bug 54194
18 years ago
17 years ago

People

(Reporter: srinivasa yarlagadda, Assigned: dcone (gone))

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: NS6PR3(ID:2000092723) on Sparc_Solaris8
description:
1. Open a mail/message in the messagenger.
2. Print the mail and observ the browser crashing.
3. This happend 100%
4. Printing file/webpage is normal and not crashing the browser
5. The console assertion is:

blackcat% WEBSHELL+ = 7
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[JavaScript Warning: "assignment to undeclared variable printEngi
neWindow" {file: "chrome://messenger/content/mailWindowOverlay.js" line: 656}]"
 nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location:
"JS frame :: chrome://messenger/content/mailWindowOverlay.js :: PrintEnginePrint
 :: line 656"  data: yes]
************************************************************
An error occurred executing the cmd_print command
WEBSHELL+ = 8
Enabling Quirk StyleSheet
imap_message://sy107908@ha3mpk/INBOX#543
Enabling Quirk StyleSheet
WEBSHELL+ = 9
JavaScript strict warning:
 line 8: function onget does not always return a value

JavaScript strict warning:
 line 12: redeclaration of var index

WEBSHELL- = 8
nsWidget::~nsWidget() of toplevel: 38 widgets still exist.
nsWidget::~nsWidget() of toplevel: 36 widgets still exist.
WEBSHELL- = 7
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().: 'mRa
wPtr != 0', file ../../../dist/include/nsCOMPtr.h, line 649
###!!! Break: at file ../../../dist/include/nsCOMPtr.h, line 649
(Assignee)

Comment 1

18 years ago
Duplicate of 54194... There are some other problems with events that may 
contribute also.. so this is probably a dub of 2 or 3 bugs...

*** This bug has been marked as a duplicate of 54194 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
The crash in bug 54194 is related while loading the plugins other than
javaplugin and not crashing while printing other files. But in this case it is
crashing while printing mails only.

Comment 3

17 years ago
verif dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.