When Replying or Forwarding an e-mail the message header is mangled

VERIFIED DUPLICATE of bug 10965

Status

MailNews Core
Composition
P3
normal
VERIFIED DUPLICATE of bug 10965
19 years ago
10 years ago

People

(Reporter: marina, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PR1])

(Reporter)

Description

19 years ago
Steps to reproduce:
open an e-mail|click Reply or Forward
//note: in the Subject field there is no header

Comment 1

19 years ago
I debugged this today because I made i18n changes on 4/19.
For reply/forward, nsIMessage gets original mail's info (to, cc, subject).
In the code below, msgHdr is null so we get an error and the subject string
unchanged (it is initialized as empty string). I think this is the reason that
we don't get headers (because they are empty strings).
I think this is not related to the change I made on 4/19 but let me know if
anything wrong with my code.

mozilla/mailnews/base/util/nsMessage.cpp
NS_IMETHODIMP nsMessage::GetSubject(nsString &resultSubject)
{
	if(mMsgHdr)
		return mMsgHdr->GetSubject(resultSubject);
	else
		return NS_ERROR_FAILURE;
}

Updated

19 years ago
QA Contact: 4080 → 4114

Comment 2

19 years ago
I don't think that reply or forward is implemented yet.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 3

19 years ago
What Lisa said. Marking invalid.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
marking verified as invalid.  Once these features are implemented, we'll try out
the functionality.
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 5

19 years ago
As far as i understand Reply and Forward are implemented now. When getting a
replyied message you see all non-ascii garbled (not in the thread pane, in the
message header). So reopening

Updated

19 years ago
Resolution: INVALID → ---

Comment 6

19 years ago
Clearing Invalid resolution due to ReOpen of this bug.

Comment 7

19 years ago
JF - please assess the bug and assign a target milestone.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M10

Updated

19 years ago
Whiteboard: [PR1]

Comment 8

19 years ago
I think we probably want to fix this for PR1

Comment 9

19 years ago
And we need to have time to look at the fix carefully well before
Beta 1. We are trying to fix the body problem for M9 right now --
Bug 11763. I might also add that Latin 1 header quoting was working
pre-necko (7/28/99 build) and so this is really a regression for
Latin 1 even for M9. See my comment in Bug 11763 on this.

Updated

19 years ago
Summary: When Replying or Forwarding an e-mail the message header is lost → When Replying or Forwarding an e-mail the message header is mangled

Comment 10

19 years ago
When I say "working" for pre-necko, I mean "POP3". IMAP quoting
seemed to have been broken according to rhp.

Comment 11

19 years ago
Marina, please update the status of this bug with regard to HTML/Plain
text Latin 1 send for both POP3 and IMAP servers.

Comment 12

19 years ago
Marina, is this a duplicate of another bug reported? Bug 10965.
If so, mark one or other as a duplicate. If they are duplcates,
then it might be better tokeep Bug 10965 alive rather than this one.
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 13

19 years ago
I marked this one as a dup of 10965 since it is the same problem and i agree
with Kat it's better to keep 10965 alive

*** This bug has been marked as a duplicate of 10965 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 14

19 years ago
Verified as duplicate
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.