Create "What's New" page for 3.6.2

VERIFIED FIXED

Status

www.mozilla.org
General
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: lmesa, Assigned: sgarrity)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
We want to make a few changes for the 3.6.2 "What's New" page.

-Take out Wordmark and update with Meta font of 3.6.2
-Change header of page to compensate for removal of wordmark.
-Add release notes link for 3.6.2
(Reporter)

Updated

9 years ago
Assignee: nobody → jslater

Comment 1

9 years ago
For the header area, I'm recommending that we replace the Firefox 3.6 wordmark with headline that reads "Welcome to Firefox 3.6.2" (written in Meta, that could be updated easily for future releases), with the current "Thanks for supporting..." copy below as a subhead. The Firefox logo and other elements on the page would remain as is.
(Reporter)

Comment 2

9 years ago
Steven, could you take a stab at implementing this? We're not sure how these changes are going to look with the page design, so the sooner we see what it looks like, the more time we have to make changes ;)
Assignee: jslater → steven
(Assignee)

Comment 3

9 years ago
Created attachment 431347 [details]
3.6.2 What's New page mockup

Is this the right idea for the header?

Where should the release notes link go, and how should be worded? Perhaps in place of the "More Firefox 3.6 Features" link, or in addition to it?

Comment 4

9 years ago
(In reply to comment #3)
> Is this the right idea for the header?
Perfect, thanks!
 
> Where should the release notes link go, and how should be worded? Perhaps in
> place of the "More Firefox 3.6 Features" link, or in addition to it?
If you look at the live What's New page - http://www.mozilla.com/en-US/firefox/3.6/whatsnew/ - we have a "See What's New" link down at the bottom. Let's just replace that with a link that reads "Release Notes".

Thanks much-
(Assignee)

Comment 5

9 years ago
This has been set up. However, until the product-details library on the stage server is set to have 3.6.2 set as the LATEST_FIREFOX_VERSION, you'll see another variation of this page.

In the mean time, you can preview it our our development server: http://mozilla-com-trunk.silverorange.com/en-US/firefox/3.6.2/whatsnew/

Ping me directly for the t0p s3cr3t password.
(Assignee)

Comment 6

9 years ago
Also note that this 3.6.2 whatsnew page is based on a copy of the 3.6 whatsnew page, so it includes the "default", "stumbleupon", "thunderbird", and "reminderfox" random promos. If it should not include these, let me know.

Comment 7

9 years ago
(In reply to comment #6)
> Also note that this 3.6.2 whatsnew page is based on a copy of the 3.6 whatsnew
> page, so it includes the "default", "stumbleupon", "thunderbird", and
> "reminderfox" random promos. If it should not include these, let me know.

Pascal & Julie, we're setting up a slightly new version of the 3.6.2 What's New page. Can you confirm what the rotation should be in the lower right promo spot? 

On the live http://www.mozilla.com/en-US/firefox/3.6/whatsnew/ page it's now just StumbleUpon one and the general AMO one (with Rock Your Firefox coming soon, I think). Is that what you want for 3.6.2, too?
On the live What's New for 3.6 we have StumbleUpon, ReminderFox, Thunderbird and the generic AMO promotion in a randomized rotation.  I'm not informed about adding Rock Your Firefox to this (which is fine by me).

Would be great if we could keep the rotation as is. :)
(Assignee)

Comment 9

9 years ago
Note that we will have to add the Rock Your Firefox promo spot to this 3.6.2 whatsnew page in addition to adding it to the 3.6 whatsnew page if it does need to be on both.

Comment 10

9 years ago
(In reply to comment #8)
> Would be great if we could keep the rotation as is. :)
Absolutely. Apologies for my confusion in comment #7.

(In reply to comment #9)
> Note that we will have to add the Rock Your Firefox promo spot to this 3.6.2
> whatsnew page in addition to adding it to the 3.6 whatsnew page if it does need
> to be on both.
I just confirmed with the AMO team that we want the RYF promo to be added to the rotation on both the 3.6 and 3.6.2 pages (and presumably later ones after that).

So, just to confirm: for the lower right promo spot, we should add in the RYF promo as detailed in bug 549489, but we shouldn't remove any of the existing ones.

Also, the preview on the SO dev server looks great. Thanks!
(Assignee)

Comment 11

9 years ago
The Rock Your Firefox promo has been added to this 3.6.2 whatsnew page in trunk in r64103.
(Reporter)

Comment 12

9 years ago
Looks good to me!
(Reporter)

Comment 13

8 years ago
QA?
Looks fine to me; tested:

* rotation
* all links
* doctype validation
* personas preview
(Reporter)

Comment 15

8 years ago
What files should we be pushing, Steven?
(Assignee)

Comment 16

8 years ago
Merged everything to stage in r64354. Preview here: https://www.authstage.mozilla.com/en-US/firefox/3.6.2/firstrun/

The following files can be pushed to production:
         stage/en-US/firefox/3.6.2
         stage/en-US/firefox/3.6.2/whatsnew
         stage/en-US/firefox/3.6.2/whatsnew/index.html
         stage/style/firefox/3.6/firstrun-page.css

Comment 17

8 years ago
(In reply to comment #16)
> Merged everything to stage in r64354. Preview here:
> https://www.authstage.mozilla.com/en-US/firefox/3.6.2/firstrun/

Laura and I are both getting a 404 for this link...any ideas?
(Assignee)

Comment 18

8 years ago
(In reply to comment #17)
> Laura and I are both getting a 404 for this link...any ideas?

Probably because I gave you the wrong link. Sorry:

https://www.authstage.mozilla.com/en-US/firefox/3.6.2/whatsnew/

Comment 20

8 years ago
Just pushed the files via Kubla.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified fixed https://www.mozilla.com/en-US/firefox/3.6.2/whatsnew/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.