Add users to the CC list of a bug when a request is made of them, with a preference

RESOLVED DUPLICATE of bug 301656

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 301656
9 years ago
9 years ago

People

(Reporter: mkanat, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
(I thought this had already been filed, but I guess not.)

  When I get a request, I usually want to be CC'ed on the bug, and often I am not. Sometimes there is discussion that happens after the request that is important to the request, but it gets missed because the requestee wasn't CC'ed. This is a problem from both the requestor's side (who wants the requestee to see the comments) and the requestee's side (who wants to see the comments/changes).

  There are two possible solutions that I can think of:

  1) Add a preference column for "requestee" and treat them somewhat like a CC.

  The problem with this is that the role goes away when the request is canceled or addressed, but sometimes I want to see what happens after a request is canceled or addressed. That is, say I mark a patch review-, and then somebody responds, but I don't see the response because I'm not on the CC list! So this solution doesn't really address the whole problem.

  2) Add a preference called "Add me to the cc list of a bug when somebody makes a request of me" or something like that. It would be on by default.

  I think that this is nice, because it allows people to opt-out of the feature for installations where it doesn't make sense, or where people don't want the behavior, but for most people in most situations, it handles the problem nicely. The only remaining problem is when the requester doesn't know that the requestee has turned off this preference, but that's the requestee's preference, so they probably have some reason for setting it that way and don't want to be CC'ed. They will know to CC themselves, because they turned off the preference.
Whiteboard: DUPEME

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Target Milestone: Bugzilla 3.8 → ---
Duplicate of bug: 301656
You need to log in before you can comment on or make changes to this bug.