Last Comment Bug 549471 - Freeze on reloadAllLivemarks()
: Freeze on reloadAllLivemarks()
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: 3.6 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 661445
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-01 15:29 PST by Marcin Szewczyk, Wodny
Modified: 2011-06-21 02:23 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Marcin Szewczyk, Wodny 2010-03-01 15:29:59 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091216 Iceweasel/3.5.8 (like Firefox/3.5.8)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091216 Iceweasel/3.5.8 (like Firefox/3.5.8)

Firefox freezes after executing reloadAllLivemarks() - i.e. refreshing all Live Bookmarks.

Probably the number of Live Bookmarks matters - about 15 for me. And the poor connection as well.

The problem is that the refreshing process should be done in background - like loading tabs, but it freezes the browser for a couple of seconds.

Reproducible: Always

Steps to Reproduce:
1. Add about 15 Live Bookmarks
2. Execute reloadAllLivemarks()
3.
Actual Results:  
Firefox freezes for at least couple of seconds.

Expected Results:  
Firefox should not freeze.

The command is easily available thanks to for example LiveClick extension.

Another method to execute reloadAllLivemarks() is to enter this into the JS console:
Components.classes["@mozilla.org/browser/livemark-service;2"].getService(Components.interfaces.nsILivemarkService).reloadAllLivemarks();
Comment 1 Tyler Downer [:Tyler] 2011-02-06 11:07:20 PST
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Comment 2 Marcin Szewczyk, Wodny 2011-02-06 12:04:46 PST
I'm still seeing this issue with Firefox 3.6.13 in safe-mode on a fresh profile.

Tested by adding:
http://debian.org/News/news
and
http://planet.fedoraproject.org/atom.xml
to
Live Bookmarks and executing reloadAllLivemarks() in the console.
Comment 3 Marco Bonardo [::mak] 2011-06-21 02:23:28 PDT
bug 661445 changed the method do to lazy loading rather than a plain for loop, that should solve the freeze like it solved at automatic refreshes.

Note You need to log in before you can comment on or make changes to this bug.