Closed Bug 549491 Opened 10 years ago Closed 9 years ago

"The root node is never visible" exception when details of the root node are modified

Categories

(Toolkit :: Places, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b1

People

(Reporter: marcia, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(1 file)

Seen while running Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a2) Gecko/20100228 MozillaDeveloperPreview/3.7a2 (.NET CLR 3.5.30729)

I get this filling the error console: 

Error: [Exception... "'The root node is never visible' when calling method: [nsINavHistoryResultViewer::nodeHistoryDetailsChanged]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Program%20Files%20(x86)/Mozilla%20Developer%20Preview%203.7%20Alpha%202/components/nsLivemarkService.js :: LS_insertLivemarkChild :: line 604"  data: no]
Source File: file:///C:/Program%20Files%20(x86)/Mozilla%20Developer%20Preview%203.7%20Alpha%202/components/nsLivemarkService.js
Line: 604

testing with an existing trunk profile - only addon installed is Weave Sync.
Regression from bug 520659
Blocks: 520659
Working on STR. I believe I was running one of the Litmus test cases when it happened so I will revisit that test case and see if I can repro it.
Actually, never mind.
Assignee: nobody → mano
Status: NEW → ASSIGNED
Summary: [Exception... "'The root node is never visible' when calling method: [nsINavHistoryResultViewer::nodeHistoryDetailsChanged]" → "The root node is never visible" exception when details of the root node are modified
STR: Seen while running Alpha 3

1. http://feeds.delicious.com/v2/rss/recent?min=2&count=15
2. Install feed in Unsorted Bookmarks
3. Select Feed and Reload Live Bookmark
4. Receive error in console.
Attached patch patchSplinter Review
Due to xpconnect magic, the exceptions is swallowed when this exception is thrown the normal way.  In particular, calling addVisir from the test did get to the exception line, but it didn't get to the console (probably because addVisit itself doesn't throw if updating the view failed).

Thus, I emulated the error by calling node*Changed directly.
Attachment #449395 - Flags: review?(mak77)
Comment on attachment 449395 [details] [diff] [review]
patch

>diff -r ba82b6ecb9ce browser/components/places/tests/chrome/test_bug549491.xul

>+      tree.view.QueryInterface(Ci.nsINavHistoryResultObserver)
>+          .nodeHistoryDetailsChanged(rootNode, rootNode.time, rootNode.accessCount);
>+      tree.view.QueryInterface(Ci.nsINavHistoryResultObserver)
>+          .nodeTitleChanged(rootNode, rootNode.title);

I think you could be able to QI just once
Attachment #449395 - Flags: review?(mak77) → review+
I fixed my comment before pushing.
http://hg.mozilla.org/mozilla-central/rev/ee7eb27ef77b

with a subsequent push I've also fixed possible random failures due to sync removeAllPages calls.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a6
Hey, you didn't have to do this (but thanks!). Next time, please ping via email or IRC.
no problem, it was a trivial change and I was already pushing.
Duplicate of this bug: 555651
You need to log in before you can comment on or make changes to this bug.