Intermittent failure in test_xhr.html | An error occurred - xmlDoc.getElementById("user") is null at http://localhost:8888/tests/toolkit/components/passwordmgr/test/test_xhr.html:110

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure, regression})

Trunk
x86
Mac OS X
intermittent-failure, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/passwordmgr/test/test_xhr.html?force=1 has been in the tree since March 2008, without ever having had a bug filed against it.

Today, two out of eight runs have failed the same way.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267560951.1267562074.2654.gz
OS X 10.5.2 mozilla-central debug test mochitests-5/5 on 2010/03/02 12:15:51
s: moz2-darwin9-slave16
5540 INFO TEST-PASS | /tests/toolkit/components/passwordmgr/test/test_xhr.html | xhrLoad running for test 1
5541 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/components/passwordmgr/test/test_xhr.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - xmlDoc.getElementById("user") is null at http://localhost:8888/tests/toolkit/components/passwordmgr/test/test_xhr.html:110

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267583111.1267584339.12107.gz
OS X 10.5.2 mozilla-central debug test mochitests-5/5 on 2010/03/02 18:25:11
s: moz2-darwin9-slave16
5540 INFO TEST-PASS | /tests/toolkit/components/passwordmgr/test/test_xhr.html | xhrLoad running for test 1
5541 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/components/passwordmgr/test/test_xhr.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - xmlDoc.getElementById("user") is null at http://localhost:8888/tests/toolkit/components/passwordmgr/test/test_xhr.html:110

I was suspicious about it being the same slave both times, but that slave had at least one green run of the same suite in between the two failures, so that's more likely to be just the way the master now looks for a slave that did the same thing recently than the cause.
Hmm. I don't see anything obvious in the pushlog dealing with XHR, nor has anything pwmgr-related landed recently enough to have caused this...
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267604723.1267605957.6963.gz
OS X 10.5.2 mozilla-central debug test mochitests-5/5 on 2010/03/03 00:25:23
s: moz2-darwin9-slave15
{
ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/components/passwordmgr/test/test_xhr.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - xmlDoc.getElementById("user") is null at http://localhost:8888/tests/toolkit/components/passwordmgr/test/test_xhr.html:110
JavaScript error: http://localhost:8888/tests/toolkit/components/passwordmgr/test/test_xhr.html, line 110: xmlDoc.getElementById("user") is null
}
(Reporter)

Comment 3

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267702018.1267703081.20502.gz
OS X 10.5.2 mozilla-central debug test mochitests-5/5 on 2010/03/04 03:26:58
s: moz2-darwin9-slave09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267815852.1267817142.20853.gz
OS X 10.5.2 mozilla-central debug test mochitests-5/5 on 2010/03/05 11:04:12
s: moz2-darwin9-slave17

Comment 5

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1280097443.1280098560.1860.gz&fulltext=1 :

PROCESS-CRASH | /tests/toolkit/components/passwordmgr/test/test_xhr.html | application crashed (minidump found)
Operating system: Windows NT
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 9

7 years ago
Been more than a year since we saw something that *was* this, as opposed to piling on something which was not.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.