Movies.com trailers don't load in 3.6.x (doesn't affect all systems / intermittent effect)

RESOLVED INCOMPLETE

Status

()

Core
Plug-ins
--
major
RESOLVED INCOMPLETE
8 years ago
4 years ago

People

(Reporter: Charles, Assigned: roc)

Tracking

({flashplayer, regression})

Trunk
x86
Windows 7
flashplayer, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -, blocking1.9.2 -)

Details

(Reporter)

Description

8 years ago
Running movie trailers from Movies.com produces a window but the download does not start.

It is a regression in 3.6 and fixed in 3.7preAlpha
(Reporter)

Updated

8 years ago
Component: Extension Compatibility → Plug-ins
Keywords: flashplayer, qawanted, regression, regressionwindow-wanted
Product: Firefox → Core
QA Contact: extension.compatibility → plugins
Version: 3.6 Branch → 1.9.2 Branch
Charles, can you point me to a url that shows this problem?
(Reporter)

Comment 2

8 years ago
It doesn't really matter which video from what I could tell.  The video is embedded so the only link I can give you is http://www.movies.com/movie-trailers
So I just tried 3.6.  I load the page, click the "A Nightmare on Elm Street: Trailer 2" thumbnail.  The trailer plays (though not centered in the space that opens up for it).

Are you seeing something different?  If so, how do I go about reproducing what you're seeing?

In case it matters, I'm on Mac; I can try Windows 7 tomorrow.

Comment 4

8 years ago
I tried to bisect this on windows xp using the prince of persia trailer <http://www.movies.com/movie-trailers/prince-of-persia/1318621615/>. It appears to fail randomly for me so I am not entirely positive about my results. The first 1.9.2 build on 2009-08-13-12 showed the problem so any fix on 1.9.1 would have come after that I think. It seems to be fixed on trunk maybe sometime in 2010-01 maybe in the 2010-01-20 - 2010-01-31 range perhaps due to OOPP landings. If no one beats me to it, I'll bisect 1.9.1 during my unmetered access saturday night.

Comment 5

8 years ago
Ok. looking solely at mozilla-central.

last good build: 2009-07-21-04 http://hg.mozilla.org/mozilla-central/rev/f2a58ffcd00c

first bad build: 2009-07-22-04 http://hg.mozilla.org/mozilla-central/rev/02f8bf10f441

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f2a58ffcd00c&tochange=02f8bf10f441
Keywords: qawanted, regressionwindow-wanted
Perhaps fallout from bug 339548?
blocking1.9.2: --- → ?
blocking2.0: --- → ?
Roc: do you agree with comment 6?
OK, marking the regression, then. So, Roc, this is a bad functional regression; do we know what's needed to be done to fix it? I think this blocks, just trying to determine if I think it blocks .3 or some future dot release.
Blocks: 339548
Whiteboard: [needs answer from roc]
Let's fix it for 1.9.3.
Assignee: nobody → roc
Whiteboard: [needs answer from roc]
I see this in mozilla-central with OOPP turned off.

However, I'm beginning to doubt it's bug 339548, because the plugin renders correctly --- the controls etc are just fine, events are dispatched correctly and the controls respond --- it just doesn't play the video.
Also, the window structure and layout with and without OOPP is the same.
OTOH, nothing else in the changeset list would make sense.
The movies.com trailing is windowless (wmode=opaque). It's in an IFRAME, but loading the frame directly doesn't work either:
http://www.movies.com/HDFandangoPlayer.aspx?src=1434889748&movie=Iron%20Man%202&video=Iron%20Man%202:%20Trailer%202
Not blocking 1.9.2 since it's intermittent and the failure state is unclear at this time. Should that change, please renominate!
blocking1.9.2: ? → -
Summary: Movies.com trailers don't load in 3.6.x → Movies.com trailers don't load in 3.6.x (doesn't affect all systems / intermittent effect)
Blocking, beta1 for now, but feel free to push this further out if you think the fix isn't going to be very risky.
blocking2.0: ? → beta1+

Updated

8 years ago
blocking2.0: beta1+ → beta2+
Version: 1.9.2 Branch → Trunk

Updated

8 years ago
blocking2.0: beta2+ → betaN+

Updated

7 years ago
blocking2.0: betaN+ → -

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.