Ignore Thread in newsgroup crashes systematically

VERIFIED DUPLICATE of bug 534858

Status

--
critical
VERIFIED DUPLICATE of bug 534858
9 years ago
9 years ago

People

(Reporter: shill, Unassigned)

Tracking

({crash, crashreportid})

SeaMonkey 2.0 Branch
x86
Windows XP
crash, crashreportid

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100205 SeaMonkey/2.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100205 SeaMonkey/2.0.3

I read several Usenet newsgroups. I've kill-filed a particular poster.

My filter rule used to be:
if From contains <him> then "Delete Message"

I recently changed the filter rule to:
if From contains <him> then "Ignore Subthread"

Two weeks ago, this poster started a new thread.
His original message was deleted by the first rule.
His next messages were made to be ignored by the second rule.

Even with "Show Ignored" disabled (i.e. Hide Ignored threads) and "View Threads with Unread" selected, Seamonkey does show the thread although there are no unread messages (this is a minor bug in itself).

More importantly, if I try to kill the entire thread (K or Ignore Thread from the menu) the application immediately crashes.

This bug might be related to bug 454768

I will make Seamonkey crash one more time, then reload the newsgroup, so that the same rule is applied to every message.

Reproducible: Always




Report IDs (from about:crashes)
bp-02a8e3b8-a647-49ef-9ecd-b3cdb2100304	04/03/2010	14:01
bp-8f5ee22e-7514-40f9-b281-bba572100304	04/03/2010	13:46
(Reporter)

Comment 1

9 years ago
The crash occurs in safe mode too.

bp-5747027c-b382-405c-ae46-5bb022100304    04/03/2010    15:27
bp-694a6052-63b6-44fe-80cc-6329b2100304    04/03/2010    15:21

Updated

9 years ago
Keywords: crash, crashreportid
Version: unspecified → SeaMonkey 2.0 Branch
(Reporter)

Comment 2

9 years ago
The problem seems to be a bad interaction bewteen

1) Newsgroup Message Filters => the Ignore Subthread action (which was not available in Seamonkey 1.x AFAIR)
2) Manually ignoring entire threads using K (or the Ignore Thread menu option)

I ran the following test.

Quit Seamonkey
Delete the newsgroup's message summary (comp.arch.msf)
Restart Seamonkey
Select the comp.arch newsgroup
(Seamonkey downloads the group's message headers (AFAIU))

The thread "Looking for good source of information on Intel internal floating-point representations." shows up in my list of "threads with unread" even though I've actually read all the messages. If I show ignored threads, I can see that $TROLL has posted one message to this thread (his message has received no follow-up). If I hit K to ignore the thread, Seamonkey crashes.

bp-f3265f3d-e3b9-4bba-baf3-808702100304    04/03/2010    15:38
(Reporter)

Comment 3

9 years ago
This bug might be related to bug 534858. (Might even be a dupe)
Adding David Bienvenu to CC (if I can).

Comment 4

9 years ago
yes, sure looks like a dup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 534858

Updated

9 years ago
Severity: normal → critical
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.