All users were logged out of Bugzilla on October 13th, 2018

"ASSERTION: Not going to invalidate the correct area" with tweak to SVG filter & very large 'y'

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Created attachment 430467 [details]
testcase

###!!! ASSERTION: Not going to invalidate the correct area: 'Not Reached', file /Users/jruderman/mozilla-central/layout/svg/base/src/nsSVGUtils.cpp, line 641
Created attachment 430474 [details]
testcase 2 (reduced value)

Same as original testcase, except I:
 - added whitespace for readability
 - reduced the very-large 'y' value to the lowest integer value that reproduces the issue.

That minimal "bad" y-value is 2147483584, which happens to be 2^31 - 64.

So, this looks like this bug depends on us overflowing nscoord_MAX somewhere.
OS: Mac OS X → All
Hardware: x86 → All
Summary: "ASSERTION: Not going to invalidate the correct area" with SVG filter, animation → "ASSERTION: Not going to invalidate the correct area" with tweak to SVG filter & very large 'y'
Created attachment 430478 [details]
testcase 3 (no SMIL)

This testcase has no SMIL -- instead, it uses js to tweak the filter's "x" value.  This triggers a single instance of the assertion. (for the single tweak)

The setTimeout() in this testcase is required -- we only seem to trigger this issue if the tweak happens *after* our initial paint.  (If I remove the setTimeout call, or reduce the timeout to 0, then I don't hit the assertion.)
Attachment #430478 - Attachment is patch: false
Attachment #430478 - Attachment mime type: text/plain → image/svg+xml

Comment 3

5 years ago
Bug 738192 removed the assertion:
https://hg.mozilla.org/mozilla-central/diff/5c26b1320e1a/layout/svg/base/src/nsSVGUtils.cpp
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.