Messages cannot be un-marked for deletion

VERIFIED DUPLICATE of bug 59694

Status

P3
normal
VERIFIED DUPLICATE of bug 59694
18 years ago
10 years ago

People

(Reporter: bugzilla-mozilla-org, Assigned: Bienvenu)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-3 i686; en-US; m18) Gecko/20001002
BuildID:    2000100206

The 'deleted' flag of a message (IMAP) should be toggled with the 'delete'
button, similar to Netscape 4.7x.  Currently it's only possible to undo the last
deletion (or deletions), which isn't always what's desired.

Reproducible: Always
Steps to Reproduce:
Set up an IMAP account in Mozilla, and have it mark messages for deletion.  Then
mark several messages as deleted and attempt to unmark one of them with
Edit/Delete Message or the Delete button.  Compact the folder.

Actual Results:  "Unmarking" the message does not change the icon from deleted,
and compacting the folder removes all messages that were marked (including the
one that was "unmarked").

Expected Results:  The icon should change back to normal, and the message should
remain in the folder after compacting.

There doesn't seem to be a workaround--copying or moving the message also copies
the deleted flag, meaning that the message will be deleted from the target
folder when it's compacted.

Comment 1

18 years ago
Setting bug status to New.  peterj@liberate.com, I've updated your Bugzilla
account permissions so that bugs you file will start out as New rather than
Unconfirmed.  Please email me if you have any questions.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
reassigning to sspitzer and nominating mail3
Assignee: putterman → sspitzer
Keywords: mail3
(Assignee)

Comment 3

18 years ago
taking
Assignee: sspitzer → bienvenu
Component: Mail Window Front End → Networking - IMAP

Comment 4

18 years ago
changing qa to huang.  Karen do we have a dup of this bug, I thought you logged one?
QA Contact: esther → huang
(Assignee)

Comment 5

18 years ago
yes, it's a dup of 59694

*** This bug has been marked as a duplicate of 59694 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Thanks, David. 
Verified as dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.