Last Comment Bug 550400 - Fire UserDataHandler for removed nodes
: Fire UserDataHandler for removed nodes
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: x86 Windows Vista
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-04 20:49 PST by Brett Zamir
Modified: 2010-03-05 01:43 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Demonstrates lack of NODE_DELETED support and workaround but only for some non-Mozilla browsers (2.58 KB, text/html)
2010-03-04 20:50 PST, Brett Zamir
no flags Details

Description Brett Zamir 2010-03-04 20:49:13 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: 

I see that when using the DOM's setUserData() UserDataHandler's, all of the events work, except for NODE_RENAMED (since renameNode() is not yet supported) and NODE_DELETED. I'm attaching a simple test case (you can ignore the first 'if' block which just demonstrates other browsers can be made to support NODE_DELETED (in JavaScript)). I see that Bug 337541 was marked as WONTFIX and Bug 324871 removed that support, but I'd hope there'd be some way to fix it so NODE_DELETED did trigger.

Since this information isn't otherwise readily serializable (as it would be adding namespaced attributes or the like), it's convenient to be able to trigger these user data handlers.

Thanks...

Reproducible: Always
Comment 1 Brett Zamir 2010-03-04 20:50:33 PST
Created attachment 430516 [details]
Demonstrates lack of NODE_DELETED support and workaround but only for some non-Mozilla browsers
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2010-03-04 21:23:23 PST
I believe the decision on NODE_DELETED is that we have no plans to implement it.
Comment 3 Jonas Sicking (:sicking) No longer reading bugmail consistently 2010-03-05 00:49:59 PST
Yeah, the problem is that it's too hard to implement interoperably due to being too dependent on GC behavior.
Comment 4 Peter Van der Beken [:peterv] 2010-03-05 01:43:47 PST
Right, see bug 324871, comment 17.

Note You need to log in before you can comment on or make changes to this bug.