Closed Bug 550484 Opened 10 years ago Closed 9 years ago

Hardcoded widths for pref-proxies-advanced and pref-languages.add dialogs

Categories

(SeaMonkey :: Preferences, defect)

defect
Not set

Tracking

(seamonkey2.2 wontfix, seamonkey2.3 wontfix, seamonkey2.4 fixed, seamonkey2.5 fixed)

RESOLVED FIXED
seamonkey2.5
Tracking Status
seamonkey2.2 --- wontfix
seamonkey2.3 --- wontfix
seamonkey2.4 --- fixed
seamonkey2.5 --- fixed

People

(Reporter: milupo, Assigned: iann_bugzilla)

Details

Attachments

(3 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hsb-DE; rv:1.8.1.23) Gecko/20090825 SeaMonkey/1.1.18
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; hsb-DE; rv:1.8.1.23) Gecko/20090825 SeaMonkey/1.1.18

The dialog boxes are too narrow. They and - unfortunately a lot of other dialog boxes - have been hardcoded. I don't know why widths are still hardcoded after so many years of localizing Mozilla builds. All dialog boxes should generally be customizable for localizers. I don't understand why that is over and over again ignored. In the two cases I mentioned the width is even defined by a fixed number of *characters*! Different languages have differently long words! In pref-proxies-advanded.xul a width of "54ch" is defined and in pref-languages-add.xul a width of "41ch". A width in *em* has at least a certain margin but a width in *characters* is nonsense! It's only valid for English! I'm sure there are a lot of bugs where is complained about too small widths and heights. They all wouldn't exist if widths and heights wouldn't be hardcoded!

Please make at least the widths and heights of these two dialog boxes customizable for localizers. 

Reproducible: Always

Actual Results:  
In Upper Sorbian the dialog boxes for Preferences --> Advanced --> Proxies --> Advanced and Preferences --> Navigator --> Languages --> Add are too narrow.

Expected Results:  
Dialog boxes should be customizable that text is fully readable in them.
Version: unspecified → SeaMonkey 2.0 Branch
SeaMonkey 1.1 will only accept security and stability (crashes) fixes.

Reporter, can you try and reproduce with SeaMonkey v2.0.3 ?
Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20110511 Firefox/4.0.1 SeaMonkey/2.1

I'll confirm that the 'Advanced Proxy Preferences' dialog window is not resizable.

In FF4 - FF6 (they call the window 'Connection Settings') it is also not resizeable.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: SeaMonkey 2.0 Branch → Trunk
This patch:
* Adds entities for the style for the two dialogs.
* Uses the new entities to style the two dialogs.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #533389 - Flags: review?(neil)
(In reply to comment #0)
> A width in *em* has
> at least a certain margin but a width in *characters* is nonsense!
Since em is a height unit, a width in em is nonsense...

The strings in the dialogs should all wrap as appropriate. (Indeed, in the proxy dialog, some of them already wrap in English.) Of course there may be something that I'm overlooking, but I'd need a screenshot of the problem.
Shows the other field being too narrow.
This is the Norwegian advanced proxies dialog, ip fields are smaller than they should be.

There are similar issues with the Slovakian and Lithuanian ones.
Comment on attachment 533389 [details] [diff] [review]
Add ability to localise pref-proxies-advanced and pref-languages.add dialogs patch v1.0

>-            style="width: 41ch; height: 28em;">
We can probably do without this style and just let the dialog size itself.

>-            style="width: 54ch;"
Your screenshot doesn't seem to show a problem...
(In reply to comment #7)
>(From update of attachment 533389 [details] [diff] [review])
>>-            style="width: 41ch; height: 28em;">
>We can probably do without this style and just let the dialog size itself.
> 
>>-            style="width: 54ch;"
>Your screenshot doesn't seem to show a problem...
Actually on both cases removing the style isn't quite the correct fix, you also need to set style="width: 1px;" on the descriptions to get them to wrap. (And the add languages dialog becomes narrower in English, probably caused by the size on the textbox being too low.)
Changes since last version (as suggested by reviewer):
* Just remove the style from prefwindows.
* Add style to each description element.
* Increase size of add-language textbox.
Attachment #533389 - Attachment is obsolete: true
Attachment #551506 - Flags: review?(neil)
Attachment #533389 - Flags: review?(neil)
Comment on attachment 551506 [details] [diff] [review]
With main styles removed, description styles added and textbox size increased [Checked in: Comment 11]

Interestingly this now makes the listbox size to the width for the longest language, which is apparently "Macedonian/Macedonia, F.Y.R. of  [mk/mk]"
Attachment #551506 - Flags: review?(neil) → review+
Comment on attachment 551506 [details] [diff] [review]
With main styles removed, description styles added and textbox size increased [Checked in: Comment 11]

http://hg.mozilla.org/comm-central/rev/aef8948fd115

Requesting approval this low risk fix to comm-aurora
Attachment #551506 - Attachment description: With main styles removed, description styles added and textbox size increased → With main styles removed, description styles added and textbox size increased [Checked in: Comment 11]
Attachment #551506 - Flags: approval-comm-aurora?
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.5
Attachment #551506 - Flags: approval-comm-aurora? → approval-comm-beta+
Pushed to comm-beta
http://hg.mozilla.org/releases/comm-beta/rev/73cf5f055600
Already in comm-aurora.
You need to log in before you can comment on or make changes to this bug.