Closed Bug 550669 Opened 10 years ago Closed 10 years ago

Some attachment don't display properly

Categories

(MailNews Core :: Attachments, defect, major)

1.9.2 Branch
x86
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 538407

People

(Reporter: Aureliano, Unassigned)

References

Details

(Keywords: regression, testcase)

Attachments

(1 file)

Attached file testcase
I see one regression between 3.0.3 and 3.1b1: some attachment isn't display properly (maybe when is send by outlook?).

I have 2 messages that are affects by this issue: both are displayed right with TB 3.0.3 and wrong with current 3.1b1 (as inline and not into attachments pane).

ps: I have attached here an email testcase that I have received from my friend (I have deleted personal informations).
Component: Mail Window Front End → Attachments
Product: Thunderbird → MailNews Core
QA Contact: front-end → attachments
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Reproduced in Safe Mode with profile B3ta on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2pre) Gecko/20100302 Lanikai/3.1b1 ID:20100302141414

WFM in normal mode with profile Normal on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.8) Gecko/20100216 Lightning/1.0b1 Thunderbird/3.0.2 ID:20100216161403

Note also that the test message loses its attachment icon in the message pane after opening (inline display) in 3.1b1.

I /think/ this belongs on the 1.9.2 branch... not sure if there's a practical difference yet, though.
Version: Trunk → 1.9.2 Branch
(In reply to comment #0)
> I see one regression between 3.0.3 and 3.1b1: some attachment isn't display
> properly (maybe when is send by outlook?).

Just ran across this again while testing another bug -- Lanikai can *create these messages itself*, just by sending a message with an attachment. (I sent a simple message to myself, from Lanikai, with a single PPS [PowerPoint Show] file attached; Lanikai displayed the attachment inline.)
I'm inclined to raise the severity accordingly, although this may not quite be justified; note especially that it's impossible to do anything with the attachments displayed this way. On consideration, I do think this should be major: a reasonably standards-compliant MUA can create these emails without much difficulty, and Lanikai is unable to handle them properly at all.

Oh, and actually I reproduced with Thunderbird/3.0.3 ID:20100227143138, not 3.0.2, sorry. (Stale canned-clipboard data, oops.)
Severity: normal → major
Jie, can you have a look to see if this was caused by the changes in bug 532603?  Thanks!
I believe this will be fixed by the patch in bug 538407, which will land today, and this is most likely a dup of bug 538407.
Yeah, I believe this was caused by my fault and should have been fixed. Please try next beta and if this bug is still there let me know.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538407
You need to log in before you can comment on or make changes to this bug.