JS/Accessible Object viewer tree has border and margins

RESOLVED FIXED

Status

Other Applications
DOM Inspector
--
trivial
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: crussell)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

9 years ago
The DOM Node, CSS Rules, Computed Style and Accessible Relations trees are plain, without border or margins. The XBL Bindings and Accessible Properties trees have borders and margins. However these seem to be justified because the trees are contained within grouping elements (tabs and groupboxes). However I don't think this applies to the JavaScript Object and Accessible Object viewers and therefore I think that those trees should not have borders or margins.
Created attachment 480443 [details] [diff] [review]
Use .plain for treeJSObject
Assignee: nobody → Sevenspade
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #480443 - Flags: review?(neil)
Created attachment 480444 [details] [diff] [review]
Use .plain for treeJSObject and cleanup
Attachment #480443 - Attachment is obsolete: true
Attachment #480444 - Flags: review?(neil)
Attachment #480443 - Flags: review?(neil)
(Reporter)

Comment 3

8 years ago
Comment on attachment 480444 [details] [diff] [review]
Use .plain for treeJSObject and cleanup

[What happened to the accessible object viewer, I can't find it any more...]
Attachment #480444 - Flags: review?(neil) → review+
Created attachment 480511 [details] [diff] [review]
change the Accessible Object viewer's tree, too [Checkin: comment 5]

(In reply to comment #3)
> [What happened to the accessible object viewer, I can't find it any more...]

Ah, I forgot the Accessible Object viewer.  That's what I get for creating a fix before tracking down the bug for it.

You can only use accessibility object viewers if the document viewer is an accessibility viewer.
Attachment #480444 - Attachment is obsolete: true
Attachment #480511 - Flags: review?(neil)
Attachment #480511 - Attachment description: change the Acessible Object viewer's tree, too → change the Accessible Object viewer's tree, too
Comment on attachment 480511 [details] [diff] [review]
change the Accessible Object viewer's tree, too [Checkin: comment 5]

Ah, I didn't see it already had r+.

Pushed: http://hg.mozilla.org/dom-inspector/rev/b15a1483408f
Attachment #480511 - Attachment description: change the Accessible Object viewer's tree, too → change the Accessible Object viewer's tree, too [Checkin: comment 5]
Attachment #480511 - Flags: review?(neil) → review+
Blocks: 592530
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

8 years ago
(In reply to comment #4)
> You can only use accessibility object viewers if the document viewer is an
> accessibility viewer.
I already tried viewing the accessibility tree :-(
I don't know then.  I always run into errors and brokenness with the a11y viewers.  I don't use them.
(Reporter)

Comment 8

8 years ago
(In reply to comment #3)
> [What happened to the accessible object viewer, I can't find it any more...]
It turns out this is bug 601101 ;-)
You need to log in before you can comment on or make changes to this bug.