Closed Bug 550967 Opened 10 years ago Closed 6 years ago

SessionStore non-trivially slows down startup

Categories

(Firefox :: Session Restore, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 810932

People

(Reporter: zpao, Unassigned)

Details

(Keywords: perf)

It's a known issue, and should be pretty obvious. Symptoms include a large CPU spike, saturated bandwidth, an unusable browser.

There might be things we can do to make it better. For example, meter tab loads and look at specific areas (e.g. maybe loading session history is a bottleneck).

The problem is described across a multitude of different bugs, some of which will be duped to new bugs. Other new bugs will be filed as we find areas to improve.
I'm profiling startup for unrelated reasons and it seems that a thread backs up sessionstore.js and fsyncs at the end. That is certainly a very small part of the slowdown but I am not sure it is necessary.
zpao, is this bug still wanted, given the other perf bugs you have opened since comment 0??
Keywords: perf
This bug is very much still wanted. Currently working on bug 810932 to improve the situation by splitting the file.
Depends on: 810932
I don't think there's much benefit in tracking this separately.
Status: NEW → RESOLVED
Closed: 6 years ago
No longer depends on: 810932
Resolution: --- → DUPLICATE
Duplicate of bug: 810932
You need to log in before you can comment on or make changes to this bug.