Update hg.mozilla.org to Mercurial 1.5.4

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: ted, Assigned: aravind)

Tracking

Dependency tree / graph
Bug Flags:
needs-downtime +

Details

(Reporter)

Description

8 years ago
Currently we're on hg 1.2 or something very old. Hg 1.5 was just released, we should at least get to 1.4.something so we're not on an ancient version. I tested our hooks+extensions+templates in bug 511305 and everything seems to work fine (and passes all the unit tests).
(Assignee)

Comment 1

8 years ago
I am building a new backend server to help with load issues on the vcview boxes, I will roll this update out as a part of that.
Assignee: server-ops → aravind
(Reporter)

Updated

8 years ago
Depends on: 551520
(Assignee)

Comment 2

8 years ago
Ted, the hg staging environment should now be up (551520), let me know if you need any more information from me to test 1.4 on that environment.
(Reporter)

Comment 3

8 years ago
Sounds good, I'll try to find the time to look at this next week. If you want to assign this to me in the interim feel free.
(Assignee)

Comment 4

8 years ago
@ted: please toss the bug back to our bucket when you are ready.
Assignee: aravind → ted.mielczarek
Component: Server Operations → Hg: Customizations
QA Contact: mrz → hg.customizations
(Assignee)

Comment 5

8 years ago
Hey Ted, I think I have it all sorted out.. hgstage.m.o is now running 

[root@dm-vcstage01 templates]# hg version
Mercurial Distributed SCM (version 1.5.3+22-24fe2629c6fd)

Give it a little testing and we should be on our way to the upgrade.
Are you running a patched Mercurial here? Why is the version not 1.5.4?
(Reporter)

Comment 7

8 years ago
The styling on /annotate/ looks busted:
http://hgstage.mozilla.org/mozilla-central/annotate/78d11f8b9cae/Makefile.in

Are you using the right templates there? The CSS file doesn't seem to match the one in our hg_templates repo:
http://hgstage.mozilla.org/mozilla-central/static/style-gitweb.css
http://hg.mozilla.org/hg_templates/file/173c563d1cb9/static/style-gitweb.css
(Assignee)

Comment 8

8 years ago
(In reply to comment #6)
> Are you running a patched Mercurial here? Why is the version not 1.5.4?

I built the rpm using the sources.  The sources have contrib/buildrpm thingy which insist of finding a .hg tree, so I actually checked stuff out from source.  The rev corresponding to 1.5.4 in http://selenic.com/repo/hg/tags is 24fe2629c6fd.

If I did that wrong, let me know.. its pretty trivial to build a new rpm.
(Assignee)

Comment 9

8 years ago
(In reply to comment #7)
> The styling on /annotate/ looks busted:

Should be fixed now, can you take a look?

> Are you using the right templates there? The CSS file doesn't seem to match the
> one in our hg_templates repo:

I was using a mish-mash of templates, now I am using ours for sure.
(In reply to comment #8)
> I built the rpm using the sources.  The sources have contrib/buildrpm thingy
> which insist of finding a .hg tree, so I actually checked stuff out from
> source.  The rev corresponding to 1.5.4 in http://selenic.com/repo/hg/tags is
> 24fe2629c6fd.

That's weird... How did you do the clone/checkout? If you did hg clone -r1.5.4, I guess that explains it. Can you do hg clone, then hg up 1.5.4, and build the rpm from that?
(Reporter)

Comment 11

8 years ago
Ok, I poked around a bunch and everything looks ok to me.
(Assignee)

Comment 12

8 years ago
(In reply to comment #10)
> That's weird... How did you do the clone/checkout? If you did hg clone -r1.5.4,
> I guess that explains it. Can you do hg clone, then hg up 1.5.4, and build the
> rpm from that?

I had originally pulled stuff like this, hg clone -r 24fe2629c6fd

I followed your suggestion and now the build says this.

[root@dm-vcstage01 mercurial]# hg version
Mercurial Distributed SCM (version 1.5.4)


@Ted: look over it one more time?  and I will schedule the upgrade.
(Reporter)

Comment 13

8 years ago
Looks good.
(Assignee)

Comment 14

8 years ago
I think this is ready to push to production.  Will try to schedule this around tomorrow nights build (tinderbox) outage.
Assignee: ted.mielczarek → aravind
Component: Hg: Customizations → Server Operations
QA Contact: hg.customizations → mrz
(Assignee)

Updated

8 years ago
Flags: needs-downtime+
(Assignee)

Comment 15

8 years ago
We should now be running 1.5.4 across the board.  Please re-open/comment here if you notice any problems.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

8 years ago
Looks like the upgrade broke a few things.


The following need to be fixed for us to be fully functional again.

573264, 573265, 573250 and 573270
Status: RESOLVED → REOPENED
Depends on: 573264, 573265, 573250, 573270
Resolution: FIXED → ---
Depends on: 573274
bug 573274 is another regression
Bug 573270 and 573274 are probably due to not updating the templates correctly.
(Assignee)

Updated

8 years ago
Depends on: 573285
It appears that since this happened pushes are not triggering builds on 1.9.2 ...
(In reply to comment #19)
> It appears that since this happened pushes are not triggering builds on 1.9.2
> ...

This is because the pushlog isn't inserting the HG host into the URL in the rss feed, which is important.
(Assignee)

Comment 21

8 years ago
Okay, is it time to consider a rollback to 1.2 across the board?  Or are we doing okay (w.r.t builds etc) and can hang on for folks to fix these issues?
(In reply to comment #21)
> Okay, is it time to consider a rollback to 1.2 across the board?  Or are we
> doing okay (w.r.t builds etc) and can hang on for folks to fix these issues?

If we can get someone to push a dummy changeset to mozilla-1.9.2 we can test the changes made to buildbot.  If buildbot picks up the change and kicks off the right builds, I am pretty sure we can live with it.

Updated

8 years ago
Depends on: 573301
As long as the trees are building and running tests I think we can live with the incidental annoyances until they can be fixed.

Updated

8 years ago
Depends on: 573395
Depends on: 574605

Updated

8 years ago
Whiteboard: [pending on depends]
(Assignee)

Comment 24

8 years ago
All done.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Updated

7 years ago
Status: RESOLVED → VERIFIED
Summary: Update to a newer Mercurial on hg.mozilla.org → Update hg.mozilla.org to Mercurial 1.5.4
Whiteboard: [pending on depends]
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.