Closed Bug 551128 Opened 15 years ago Closed 10 years ago

Problem with sending invitations of Calendar / Lightning tasks & appoinments!

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

Lightning 1.0b1
All
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 445982

People

(Reporter: danny.ddm, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1.8) Gecko/20100227 Lightning/1.0b1 Thunderbird/3.0.3

I've installed Thunderbird with the Lightning plugin.

For my work i'm setting up a mailserver (using CalDav for the Calendar).
To get started i can send myself e-mails and i can handle Calendar requests from Outlook Calendar to the Thunderbird calendar (using different e-mails).

Now my problem is i can accept from Outlook and change the date/time of the appoinment though it won't send the request e-mails which states that only I can see the changes made in the calendar.

So what is wrong with my Thunderbid / Lightning and why is it not sending my e-mails?

I've checked and unchecked the (View > Atachements inside the mails) like files are bugged. But it doesn't seem to make changes since with either of these options i can still get Outlook attachments and still Accept/Decline these.

Does anyone know what to do to fix this? 
My work is depending on this!

Reproducible: Always

Steps to Reproduce:
1. Make an Appoinment / Task
2. Invite an attendee
3. "Save and Quit" / Email the Attendees
Actual Results:  
If i look into my Error Console i get "this.baseUri is null".
Saying "file:///C:/Documents%20and%20Settings/MYUSER/Application%20Data/Thunderbird/Profiles/bmilf5h6.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/MYUSER/Application%20Data/Thunderbird/Profiles/bmilf5h6.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js Line: 190" 

Which i think means: Not sending the request e-mails.

Expected Results:  
Sending an invite e-mail to requested attendees, so I can accept/edit Appoinments/Tasks in the Calendar.

For my work i'm setting up a mailserver using CalDav, for this i'm testing out Thunderbird but it's critical to use the Calendar with appoinments and tasks.
Because i can not send any of the e-mails (atleast the attachment with the Calendar settings) it seems like we won't sadly.
Group: core-security
I'm having similar issue.
I create invites in Lightning.
I invite attendees.
No message to confirm sent invite
No message in outbox or is sent messages in TB.

[user@localhost ~]$ uname -r
2.6.34.7-56.fc13.i686
[user@localhost ~]$ rpm -qa thunderbird
thunderbird-3.1.4-1.fc13.i686
Danny, pleabargain, is this still an issue using the recently released Lightning 1.0 (compatible with Thunderbird 8)?
Version: unspecified → Lightning 1.0b1
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
Danny, pleabargin, is this still an issue with the current version 2.6.6?
Same problem here, with Thunderbird 31 and Lightning 3.3, both on Windows 8 and Ubuntu. I enabled the debug log, but nothing shows up in the log as well, sending of invitations fails silently.
Did you enable debug logging before checking the log? If not, please set calendar.debug.log and calendar.debug.log.verbose to true in aout:config - if the preferences do not exist, just create them.

What server do you use? Is server-side scheduling enabled (on the server-end)?
Thanks for your quick reply. 

I had enabled debug logging before trying, but there are still no corresponding log entries. 

I think the issue happens independent from the server. I have tried it on several machines (again Linux + Windows) using an ical file available via http. No invitations are sent. The same issue happens with the local calendar created by Thunderbird by default.
Using an ical file via http, this means you're not using a CalDAV server - so this is probably differerent from the original report.

Can you please provide the exact STR including a discription of your setup?
OK, here we go ... 

Problem: When adding an invitee to a task stored in iCal calendars, no invitations are sent. 

Environment: 
- Thunderbird 31.0 with Lightning 3.3
- both on Windows 8.1 64 Bit/Kubuntu 12.04. 64 Bit
- IMAP/SMTP server 

Repro: 

1.) Fresh installation of Thunderbird + Lightning with IMAP/SMTP server setup and working
2.) Switch to Tasks Tab (Ctrl-Shift-D)
3.) Click on "New Task" in default Calendar "Private"
4.) Set both Start and Due date (required to activate invitation menu item)
5.) Click "Settings" "Invite Attendee"
6.) Add any E-Mail address
7.) Click OK 
8.) Click "Save and Close"

Expected: 
- Invitation message sent to invitee 

Actual: 
- No invitation is sent
Based on your description you're seeing bug 445982. Lightning currently does not support task invitations neither incoming nor outgoing (and propably won't do in the near future). Only meeting invitations are supported.
Thank you for this information. A bit unfortunate for our usage scenario but at least now we know why it doesn't work.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.