Cannot seek ogg theora on https (works fine on http)

RESOLVED DUPLICATE of bug 489071

Status

()

RESOLVED DUPLICATE of bug 489071
9 years ago
9 years ago

People

(Reporter: rom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.1.8) Gecko/20100214 Ubuntu/9.10 (karmic) Firefox/3.5.8
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.1.8) Gecko/20100214 Ubuntu/9.10 (karmic) Firefox/3.5.8

If I open a ogg theora file in firefox 3.5.8, I can seek it on http, but not on https.

I just enter its url in the address bar:
http://server/file.ogv : plays and can seek
https://server/file.ogv : plays but cannot seek (and total duration is 0)

Reproducible: Always

Updated

9 years ago
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Seeking works for me when seeking over https, e.g. I can seek on https://www.safeshop.co.nz/pearce/video/shuttle-launch.ogg and on http://pearce.org.nz/video/shuttle-launch.ogg

Perhaps there's something different between our server configurations? Do you have a specific URL on which you can't seek?
(Reporter)

Comment 2

9 years ago
Your links are working fine.

But I downloaded the video, and put it on my apache server, it works with http:
http://dl.rom1v.com/noindex/shuttle-launch.ogg

But on https, I can't seek :
https://rom1v.com/shuttle-launch.ogg

I don't know what is wrong (the only difference I see is that the certificate is not verified on my server).
It looks like this is happening because the HTTPS connection is serving the file with Content-Encoding: gzip and no Content-Length, so it's not possible for Firefox to compute the correct end location to read to compute the file's duration.
Ah yes, this is effectively a duplicate of bug 489071; Firefox shouldn't send "Accept-Encoding: gzip,deflate".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489071
Sorry, my response could have been clearer.  You should probably configure your web server not to compress Ogg video files during transmission.  How to do this will depend on your web server, but in most cases there will be a list of files excluded from compression (e.g. JPEG, PNG, ZIP, etc.), and you need to add Ogg to that list.
(Reporter)

Comment 6

9 years ago
OK, thank you for your answers.

I looked into /etc/apache2/apache2.conf and some other conf files, but I didn't find any list of files excluded from compression.

Does anyone know where to configure it?
It depends very much on how your distribution has configured the defaults.  Apache 2.x will most likely be using mod_deflate for compression.  Looking at an Ubuntu 8.04 VM I have handy, the configuration is in /etc/apache2/mods-available/deflate.conf, where it only enables compression for files with a MIME type of text/html, text/plain, and text/xml.

Just in case you haven't found it already, the documentation here might help you find what you're looking for: http://httpd.apache.org/docs/2.0/mod/mod_deflate.html
(Reporter)

Comment 8

9 years ago
OK, thank you, I will try to change the configuration.

But why does it work correctly with http? Isn't the compression configuration the same for http and https?
Not necessarily, and in the case of your server it definitely isn't:

% curl --compressed -k -I https://rom1v.com/shuttle-launch.ogg
HTTP/1.1 200 OK
Date: Fri, 12 Mar 2010 19:30:51 GMT
Server: Apache
Last-Modified: Thu, 11 Mar 2010 22:00:40 GMT
ETag: "19b5e8d-4818d8baf1c4d"
Accept-Ranges: bytes
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Type: audio/ogg

% curl --compressed -k -I http://dl.rom1v.com/noindex/shuttle-launch.ogg
HTTP/1.1 200 OK
Date: Fri, 12 Mar 2010 19:31:12 GMT
Server: Apache
Last-Modified: Thu, 11 Mar 2010 22:00:40 GMT
ETag: "709-19b5e8d-4818d8baf1c4d"
Accept-Ranges: bytes
Content-Length: 26959501
Content-Type: audio/ogg
(Reporter)

Comment 10

9 years ago
Thanks for your help, I added this line in deflate.conf :
SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png|ogg|oga|ogv)$ no-gzip dont-vary

And it works.
You need to log in before you can comment on or make changes to this bug.