TM: improve array representation [meta]

RESOLVED DUPLICATE of bug 689745

Status

()

RESOLVED DUPLICATE of bug 689745
9 years ago
7 years ago

People

(Reporter: gal, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Our current array representation can be slow when dealing with 32-bit integers and doubles. We want to introduce arrays backed by typed vectors instead of a vector of jsvals and use jsvals as fallback only. We also want to tighten the read/write path and remove hole counting and avoid updating both (fill and length) at every set. Detailed plan of work to follow.
c.f. bug 486356?
Depends on: 566767
Did Typed Arrays take care of this?
Typed arrays are user-specified, this was about vanilla arrays.

The read/write path and hole/file/length situation is much better now with TI.  Using typed vectors instead of jsvals is now covered by bug 689745.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689745
You need to log in before you can comment on or make changes to this bug.