SVG/SMIL: "ABORT: Couldn't find instance time to delete"

RESOLVED FIXED

Status

()

Core
SVG
--
critical
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Jesse Ruderman, Assigned: birtles)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 431779 [details]
testcase (aborts Firefox when loaded)

###!!! ABORT: Couldn't find instance time to delete: 'found', file /Users/jruderman/mozilla-central/content/smil/nsSMILTimedElement.cpp, line 332
Confirmed on Linux debug build. (no obvious issues on opt build)
OS: Mac OS X → All
Hardware: x86 → All
Summary: "ABORT: Couldn't find instance time to delete" → SVG/SMIL: "ABORT: Couldn't find instance time to delete"
(Assignee)

Updated

8 years ago
Assignee: nobody → birtles
(Assignee)

Comment 2

8 years ago
This appears to be fixed by check in for bug 554141. Works for me on Windows.

Can anyone confirm the testcase no longer causes an abort on Mac or Linux after changeset 42519:39b66ca816a3? (http://hg.mozilla.org/mozilla-central/rev/39b66ca816a3)
(Reporter)

Comment 3

8 years ago
Crashes in a build from this morning, doesn't crash in a newer build.  So I'd say this is FIXED by bug 554141.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Depends on: 554141
(Reporter)

Comment 4

8 years ago
Crashtest: http://hg.mozilla.org/mozilla-central/rev/e5dd52dd3cb5
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.