Closed Bug 551669 Opened 11 years ago Closed 8 years ago

provide graphs by crash date too

Categories

(Socorro :: General, task)

x86
macOS
task
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 757826

People

(Reporter: timeless, Unassigned)

References

()

Details

I'd like to know if the number of crashes this week is up or down from the number of crashes last week. afaict the graphs we get are based on build id. which in my case doesn't help me, since the library that's crashing isn't ours.

The peanut gallery suggested:
you can change the value of the range_value parameter in the URL to get total numbers of crashes for the last 1, 2 and 3 weeks. then do simple subtraction. :)
-- (okay, you need a bookmarklet or something to count the table rows, too)

this is too much effort for me, i'd prefer for socorro to support graphing by crash date.
I'd really like the ability to have crashes-by-crash-date, too; I manually generated a graph for the case I was interested in (see bug 512730 comment 23 an bug 512730 comment 22), which was somewhat difficult and a little time-consuming.  

In my case it was a crash (at least partly) in our code, but it was only showing up in volume in releases (and then disappeared within a release where it originally was high), so the default graphs didn't tell me anything.  In addition, the default graphs couldn't help me narrow in on a date range where the crash suddenly dropped off so that I could try to correlate to external changes, which is what I really wanted to know.

I expect that this would also be useful for helping to determine if crashes correlate to plug-in releases and malware flare-ups, too, which I know have been issues before with some "new" Firefox crashes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 642178
Component: Socorro → General
Product: Webtools → Socorro
This actually has been implemented in bug 757826.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 757826
You need to log in before you can comment on or make changes to this bug.