Status

()

P3
normal
RESOLVED DUPLICATE of bug 70132
18 years ago
11 years ago

People

(Reporter: erik, Assigned: ftang)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Subject: WebFonts in Navigator 6
Date: Wed, 4 Oct 2000 17:48:35 +0200
From: Michael Jansson <mjan@borware.com>

You may recall my previous message regarding supporting OpenType WebFonts in 
Navigator!? I hope that you still work on font stuff, or that you
may be able to forward this message to someone that do. I'd appreciate your 
help!

The company I am running is currently working on a product known as 
FAIRY(http://www.borware.com/apps/fairy/readme.html) which support
"Server Gated WebFonts". It includes support for OpenType WebFonts for Netscape 
4.x, through a plug-in (we never did find any documentation
for 4.x WebFonts).

We would like to support 6.x as well, but are having some problems getting it to 
work. It seems that Milestone 17 of Mozilla is neither expecting
nor reacting to the event generated when new fonts are installed on Windows (the 
WM_FONTCHANGE message).

To illustrate this problem, simply create a web page that uses a font which is 
not installed, then install the font while viewing the page in Mozilla.
Another popular browser do handle this scenario. 

Would it be possible for Mozilla to redo its layout when receiving the 
WM_FONTCHANGE message? If not, then would you know if there is any
way a plug-in can force Mozilla to redo the page layout?
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Assignee)

Comment 1

18 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
Status: ASSIGNED → NEW
(Assignee)

Comment 2

18 years ago
mark all future new as assigned after move from erik to ftang
Status: NEW → ASSIGNED

Updated

17 years ago
Blocks: 70132

Comment 3

17 years ago
The fairy URL resutls in a broken HTTP redirect.
The correct URL to date is
http://www.em2-solutions.com/apps/fairy/readme.html

*** This bug has been marked as a duplicate of 91250 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

14 years ago
This is definitely not a duplicate of bug 91250. Whoever marked it as such
almost surely made an error. This bug should be re-opened or re-resolved.

Comment 6

11 years ago
> This is definitely not a duplicate of bug 91250. Whoever marked it as such
> almost surely made an error. This bug should be re-opened or re-resolved.

Keith, I am re-resolving this bug as a duplicate of bug 52746. I am pretty sure this is the correct thing to do.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

11 years ago
Argh... I just noticed the dependency on bug 70132. I'm going to resolve it as a duplicate of bug 70132 then.
No longer blocks: 70132

Updated

11 years ago
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 70132
You need to log in before you can comment on or make changes to this bug.