Daily builds after 9/14 won't start

VERIFIED DUPLICATE of bug 41057

Status

SeaMonkey
General
P3
blocker
VERIFIED DUPLICATE of bug 41057
17 years ago
13 years ago

People

(Reporter: bjrubble, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.15-4mdk i686; en-US; m18) Gecko/20000914
BuildID:    after 2000091408

None of the daily builds after 9/14 have started for me.  I get the lines of
settings (ie. MOZILLA_FIVE_HOME=) but then nothing -- no window, no error
message.  It's not taking CPU cycles or anything.  I've tried about a dozen
nightly releases since then (latest was 10/3) and got the same behavior on all
of them.  Deleting ~/.mozilla has no effect -- the settings are rebuilt then
everything stops again.

Reproducible: Always
Steps to Reproduce:
1. Go to mozilla directory
2. ./mozilla


Actual Results:  ./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.:/usr/local/lib:/usr/local/lib/mysql
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=

... hang until break

Expected Results:  Opened browser window

Mandrake 7.1, fairly stock system.  Sorry, wish I had more helpful information.

Comment 1

17 years ago
A not so wild guess:
Do you use installed builds (SEA or via installer)? If so, you must start
mozilla once as user root before normal users can start it.
See bug 41057 about this phenomena.

Comment 2

17 years ago
I had been having this problem as well.  Daily builds had been starting fine
until right around this time.  Then I would get the following messages when I
start:./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=

Gtk-WARNING **: Unable to locate loadable module in module_path: "libmetal.so",

Gtk-WARNING **: Unable to locate loadable module in module_path: "libmetal.so",

Gtk-WARNING **: Unable to locate loadable module in module_path: "libmetal.so",

Gtk-WARNING **: Unable to locate loadable module in module_path: "libmetal.so",

where the Gtk-WARNINGS are stuff I get for all gnome programs I run.

I have not been using stuff installed with installers, simply the nightly
builds.  Running mozilla as root once however, fixed this problem.
(Reporter)

Comment 3

17 years ago
Like the previous comment, I'm using the regular builds rather than an
installer.  But running once as root did fix the problem.  (PS. *Huge* leaps
since the 9/14 build -- kudos!)
(Assignee)

Comment 4

17 years ago
dupe of bug 41057 -Mozilla should not need write access to the binary directory


*** This bug has been marked as a duplicate of 41057 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verified, this is a duplicate of bug 41057 "Mozilla should not need write access
to the binary directory" - "ran mozilla as root: no problem."

Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.