DELL.com 'customize' page fails to display properly

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: Jacopo, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.3a3pre) Gecko/20100312 Minefield/3.7a3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.3a3pre) Gecko/20100312 Minefield/3.7a3pre

Layout is completely lost, contents are scrambled and overlapping, background color is black: the page is completely unusable.
Works fine in 3.6

Reproducible: Always

Steps to Reproduce:
Just open the page (whatever 'customize' page on dell.com)

Actual Results:  
Contents scrambled, page unusable.

Expected Results:  
A form like page, with many radio buttons to customize a Dell product

The problem is there from the 1st version of Firefox 3.7

Comment 1

8 years ago
With minefield, both stylesheets are seen with the mime-type 'text/plain', and this is flagged as an error. The document is in quirks mode, though.

From the error console
Error: The stylesheet http://configure-cdn.euro.dell.com/Dellstore/public/css.aspx?c=it&l=it&~set=storm75MH_NextGen&~environ=dummy was not loaded because its MIME type, "text/plain", is not "text/css".
Source File: http://configure2.euro.dell.com/dellstore/config.aspx?b=&c=it&cs=itdhs1&kc=DRSSO004&l=it&m_30=321942&oc=D00ZHD02&rbc=D00ZHD02&s=dhs
Line: 0
Error: The stylesheet http://configure-cdn.euro.dell.com/Dellstore/public/css.aspx?c=it&l=it&~set=\config\config75&~environ=dummy was not loaded because its MIME type, "text/plain", is not "text/css".
Source File: http://configure2.euro.dell.com/dellstore/config.aspx?b=&c=it&cs=itdhs1&kc=DRSSO004&l=it&m_30=321942&oc=D00ZHD02&rbc=D00ZHD02&s=dhs
Line: 0

page has this doctype:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">

---

fails
Gecko/20091224 Minefield/3.7a1pre
http://hg.mozilla.org/mozilla-central/rev/fa1e6f870ff1

works
Gecko/20091223 Minefield/3.7a1pre
http://hg.mozilla.org/mozilla-central/rev/f8b8f2f214d6

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f8b8f2f214d6&tochange=fa1e6f870ff1
Status: UNCONFIRMED → NEW
Component: General → Style System (CSS)
Ever confirmed: true
Keywords: regression
OS: Windows 7 → All
Product: Firefox → Core
QA Contact: general → style-system
Version: unspecified → Trunk
This was a purposeful change needed to fix a security bug.  See bug 524223.  dell.com was explicitly mentioned in that bug as one of the sites we'd need to convince to fix their stuff.
Assignee: nobody → english-other
Component: Style System (CSS) → English Other
Keywords: regression
Product: Core → Tech Evangelism
QA Contact: style-system → english-other
Version: Trunk → unspecified

Updated

8 years ago
Duplicate of this bug: 552185

Comment 4

8 years ago
Definitely not specific to Dell's European site, either. (See the dupe.) Moving to en-US since that's where Dell HQ is.
Assignee: english-other → english-us
Component: English Other → English US
QA Contact: english-other → english-us
Hardware: x86 → All
(Reporter)

Comment 5

8 years ago
My company is a DELL Partner. I've issued the warning through our channels.
(Reporter)

Comment 6

8 years ago
I don't know if the have heard me or if there has been a change in the latest nightly build, but right now I've made a test and everything is fine.

I'm using:

Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.3a4pre) Gecko/20100320 Minefield/3.7a4pre

Comment 7

8 years ago
Both the url in the duped bug and the one in the url field above now work correctly in the latest nightly 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100320 Minefield/3.7a4pre
@rev/45338ed951a7

and a couple of recent nightlies (making sure...). Marking as FIXED.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.