Closed Bug 552407 Opened 12 years ago Closed 12 years ago

Comm-* Closed tree hook doesn't always allow other projects to push files

Categories

(Mozilla Messaging :: Release Engineering, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file)

Attached patch The fixSplinter Review
We found this during our recent tree closures that even though just Thunderbird was closed the calendar guys couldn't push to locations under calendar/ even though the hook was designed to allow it.

Unfortunately the hook was implemented wrong, and it allowed pushes to calendar if the files were in the calendar/ directory and not any deeper sub-directories.

To fix this, I've re-implemented the part of the hook that determines which file affects which app.

Since we created the hook, Ted has redone the test scripts for the Firefox hook, so we now have a nice python harness, so I've extended that (with agreement from Ted) to cover some of the basic aspects of pushing to comm-central, including extra tests for pushing to sub-directories of the non-Thunderbird projects. This should give us more confidence that this is working correctly.

(I've not done extensive tests, but I think the ones we have should be sufficient for now).

Asking gozer to take a quick look at this - mainly the changes to treeclosure_comm_central.py are the ones I'm concerned about.
Attachment #432552 - Flags: review?(gozer)
Attachment #432552 - Flags: review?(gozer) → review+
Checked in: http://hg.mozilla.org/users/bsmedberg_mozilla.com/hghooks/rev/0d09538cedc5
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Blocks: 552483
You need to log in before you can comment on or make changes to this bug.