Closed Bug 552644 Opened 12 years ago Closed 12 years ago

JM: "Assertion failure: !TRACE_RECORDER(cx) && !wasRecording, at ../jsinterp.cpp"

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: gkw, Unassigned)

References

Details

(Keywords: assertion, regression, testcase)

(function() {
  for (e in ((function() {
    yield
  })())) return
})()


asserts at js debug shell build on JM tip without -j or -m at Assertion failure: !TRACE_RECORDER(cx) && !wasRecording, at ../jsinterp.cpp:3240
Occurs in 32-bit js debug shell on Mac 10.6.2.

autoBisect shows this is probably related to the Jaeger work-in-progress...

The first bad revision is:
changeset:   38834:acfaa77d7123
user:        David Anderson <danderson@mozilla.com>
date:        Mon Mar 15 16:22:14 2010 -0700
summary:     [JAEGER] Integrated tracing JIT into method JIT, part 1.
Blocks: Jaeger
This seems to be occurring significantly often in Mac...

But does not seem to occur in Linux 64-bit debug shells.
Assert triggered by uninit variables. These guys had to be moved up further in js_Interpret().

http://hg.mozilla.org/users/danderson_mozilla.com/jaegermonkey/rev/eddfe0cebf28
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
A testcase for this bug was automatically identified at js/src/jit-test/tests/jaeger/bug552644.js.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.