allow Gecko to build and run on Mac OS X with MOZ_IPC defined

RESOLVED FIXED in mozilla1.9.3a4

Status

()

Core
Plug-ins
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Josh Aas, Assigned: Josh Aas)

Tracking

Trunk
mozilla1.9.3a4
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

8 years ago
This patch gets Gecko building and running with MOZ_IPC defined. Plugins appear to load, subprocesses appear to start correctly, but instances cannot be created yet.

Note: We're targeting the following configuration for OOPP first: x86_64, Mac OS X 10.6, Cocoa event model, Core Graphics drawing model.
(Assignee)

Comment 1

8 years ago
Created attachment 432977 [details] [diff] [review]
fix v1.0
[Checkin: See comment 4+5]
Attachment #432977 - Flags: review?(jones.chris.g)
Attachment #432977 - Flags: review?(jones.chris.g) → review+
(Assignee)

Comment 2

8 years ago
We should probably only enable MOZ_IPC for 64-bit builds for now.

Comment 3

8 years ago
Hrm, is 32-bit really any different from 64-bit in that configuration?
(Assignee)

Comment 4

8 years ago
pushed to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/b801e211d25f
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
+
http://hg.mozilla.org/mozilla-central/rev/2b0b7d5000e5
Bustage fix, don't enable MOZ_IPC for PPC builds.
+
http://hg.mozilla.org/mozilla-central/rev/5e0706a64bba
Bustage fix, don't enable MOZ_IPC for i386 Mac OS X builds.
Target Milestone: --- → mozilla1.9.3a4
Created attachment 434089 [details] [diff] [review]
(Dv1-CC) Copy configure.in part to comm-central
[Checkin: Comment 10]
Attachment #434089 - Flags: review?(bugspam.Callek)
Created attachment 434096 [details] [diff] [review]
(Ev1-SM) Add pref("dom.ipc.plugins.enabled", ...) to SeaMonkey
Attachment #434096 - Flags: review?(bugspam.Callek)
Comment on attachment 434096 [details] [diff] [review]
(Ev1-SM) Add pref("dom.ipc.plugins.enabled", ...) to SeaMonkey

I'm not sure we can yet enable this, but even if we can; its not up to me to change this pref for us.
Attachment #434096 - Flags: review?(bugspam.Callek) → review?(neil)
Comment on attachment 434089 [details] [diff] [review]
(Dv1-CC) Copy configure.in part to comm-central
[Checkin: Comment 10]

I notice this is correct per trunk current; but was not reflected in this bug here; if the additional changes are from other bugs can you please cite them in the checkin message (or at least the changesets you are porting from); thanks.
Attachment #434089 - Flags: review?(bugspam.Callek) → review+
Attachment #432977 - Attachment description: fix v1.0 → fix v1.0 [Checkin: See comment 4+5]
Comment on attachment 434089 [details] [diff] [review]
(Dv1-CC) Copy configure.in part to comm-central
[Checkin: Comment 10]


http://hg.mozilla.org/comm-central/rev/15ad2c7f4036
Attachment #434089 - Attachment description: (Dv1-CC) Copy configure.in part to comm-central → (Dv1-CC) Copy configure.in part to comm-central [Checkin: Comment 10]
(In reply to comment #9)

I assume this comment is related to patch Ev1-SM rather than to Dv1-CC.
The latter just merges the 3 changesets from this bug.
The former already includes the wanted comment:
{
Port
*changeset ead78e10f225
*Bug 531142 - Tracking: turn on OOPP by default
too.
}
(In reply to comment #11)
> (In reply to comment #9)
> 
> I assume this comment is related to patch Ev1-SM rather than to Dv1-CC.

No, Ev1-SM is simply the pref switch for SM and is not a bug port, the stuff in Dv1-CC is not solely the stuff cited in the message there, which is why I asked you to include the port info when you pushed it.
(In reply to comment #12)
> the stuff in Dv1-CC is not solely the stuff cited in the message there

Which stuff exactly?
Comment on attachment 434096 [details] [diff] [review]
(Ev1-SM) Add pref("dom.ipc.plugins.enabled", ...) to SeaMonkey


Reviewer needed:
this is needed to fix failures on Md4 chunk!
Attachment #434096 - Flags: review?(kairo)
Attachment #434096 - Flags: review?(bugspam.Callek)

Comment 15

8 years ago
Comment on attachment 434096 [details] [diff] [review]
(Ev1-SM) Add pref("dom.ipc.plugins.enabled", ...) to SeaMonkey

AFAIK, we don't even build ipc.plugins (OOPP), so there's no real use in turning it on anywhere...
Attachment #434096 - Flags: review?(kairo) → review-
Created attachment 436964 [details] [diff] [review]
(Ev2-SM) Add pref("dom.ipc.plugins.enabled", ...) to SeaMonkey
[Checkin: See comment 18]

Ev1-SM, with comment 15 suggestion(s).

Especially given bug 555234 (...), to test MOZ_IPC seems the best solution (ftb).
Attachment #434096 - Attachment is obsolete: true
Attachment #436964 - Flags: review?(kairo)
Attachment #434096 - Flags: review?(neil)
Attachment #434096 - Flags: review?(bugspam.Callek)

Comment 17

8 years ago
Comment on attachment 436964 [details] [diff] [review]
(Ev2-SM) Add pref("dom.ipc.plugins.enabled", ...) to SeaMonkey
[Checkin: See comment 18]

confvars.sh undefines MOZ_IPC anyhow, so it always ends up false nowdays anyhow. Also, because of that, the comment is not needed and possibly even misleading here, just leave it out.
Attachment #436964 - Flags: review?(kairo) → review+
Comment on attachment 436964 [details] [diff] [review]
(Ev2-SM) Add pref("dom.ipc.plugins.enabled", ...) to SeaMonkey
[Checkin: See comment 18]


http://hg.mozilla.org/comm-central/rev/6360778aa57d
Ev2-SM, with comment 17 suggestion(s).
Attachment #436964 - Attachment description: (Ev2-SM) Add pref("dom.ipc.plugins.enabled", ...) to SeaMonkey → (Ev2-SM) Add pref("dom.ipc.plugins.enabled", ...) to SeaMonkey [Checkin: See comment 18]
You need to log in before you can comment on or make changes to this bug.