Last Comment Bug 552986 - Animated gif not displaying properly
: Animated gif not displaying properly
Status: RESOLVED DUPLICATE of bug 597174
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 3.6 Branch
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-17 10:52 PDT by aimee graham
Modified: 2010-12-01 08:19 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description aimee graham 2010-03-17 10:52:25 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Somehow the Animated Gif is not being downloaded or displayed properly. parts of the gif are not shown at all times as it moves through each state of the animation. 

Reproducible: Always

Steps to Reproduce:
Visit http://www.greennet.com 
Actual Results:  
and look at the loading gif that shows up while the images are loading.

Expected Results:  
http://www.greennet.com/images/loading.gif  - all other browsers display it correctly except firefox.
Comment 1 Ria Klaassen (not reading all bugmail) 2010-03-17 11:02:25 PDT
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2pre) Gecko/20100315 Namoroka/3.6.2pre

Looks normal here; maybe a fixed bug.
Comment 2 Rocket 2010-03-21 15:04:55 PDT
No, that "loading.gif" does not look normal. It flashes white at one frame and there is white background under the rotating colors. I searched for animated gif bugs because these smiles also have white backgroudn under the lips. And that started to happen recently. Probably after some firefox update.
http://ifrype.com//img/smilies/smile.gif

Firefox 3.6 on Windows XP here. 
Mozilla/5.0 (Windows; U; Windows NT 5.1; lv-LV; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Comment 3 Wayne Sallee 2010-10-14 09:59:39 PDT
https://bugzilla.mozilla.org/skins/custom/images/mozchomp.gif

The above is a good example that does not show up right in firefox.

This problem is affecting firefox on linux as well.

Some animated gifs work, and some do not.

At least one thing that can be done is to press the esc key to stop the anoyance.

On one linux installation, it shows as a flashing of just one frame, then nothing, then that one frame again. On another linux installation, it functions, but there is a swirl of colors in the background caused by the trail left behind by the moving image.
Comment 4 Matěj Cepl 2010-11-04 15:12:01 PDT
This is most likely duplicate of bug 597174
Comment 5 Wayne Sallee 2010-11-04 15:46:53 PDT
Yes bug 597174 is a duplicate of this bug.
This bug report was filed first. :-)
Comment 6 Matěj Cepl 2010-11-04 16:18:06 PDT
(In reply to comment #5)
> Yes bug 597174 is a duplicate of this bug.
> This bug report was filed first. :-)

But there is much more fun on other bug. :)
Comment 7 Jory A. Pratt 2010-12-01 08:19:03 PST
Other bug has a proposed patch, same issue on both bugs let just keep the other one and resolve this.

*** This bug has been marked as a duplicate of bug 597174 ***

Note You need to log in before you can comment on or make changes to this bug.