Last Comment Bug 553091 - ImageLayers should have a size
: ImageLayers should have a size
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Chris Pearce (:cpearce)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-17 15:51 PDT by Robert O'Callahan (:roc) (email my personal email if necessary)
Modified: 2011-12-02 10:56 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Robert O'Callahan (:roc) (email my personal email if necessary) 2010-03-17 15:51:28 PDT
See bug 538323 comment #29.

For smooth transitions between Images with different sizes without synchronizing with the main thread, we should give ImageLayer a size (updated on the main thread, of course) and have ImageLayer letterbox Images to that size. Then we can rely on that for all letterboxing and get rid of the letterboxing in nsVideoFrame (which currently uses transforms).
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2010-03-17 15:56:01 PDT
This isn't a priority right now since we don't support chained Oggs or any other format that supports variable frame sizes.
Comment 2 Joe Drew (not getting mail) 2011-12-02 10:56:52 PST
Chris Pearce added sizes to ImageLayers shortly after this bug was filed: http://hg.mozilla.org/mozilla-central/rev/3742af50864f

Note You need to log in before you can comment on or make changes to this bug.