unresponsive script nsBlocklistService.js:648 at startup

RESOLVED DUPLICATE of bug 542695

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 542695
8 years ago
8 years ago

People

(Reporter: Pingju, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 GTB6 (.NET CLR 3.5.30729)

Warning message pops up and FF waiting for response, the script holding is Script:file///C:/Program%20Files/Mozilla%Firefox/components/nsBlokclistService.js:648.

The default homepage at startup is http://www.google.no/firefox?client=firefox-a&rls=org.mozilla:en-US:official

Reproducible: Always

Steps to Reproduce:
1. Boot the PC
2. Start FireFox
3. The warning message pops up in a while, before FF window appears.
4. Press Stop script or continue
5. FF continue to finish startup
Actual Results:  
Do not know if there is any effect behind the scene. The browser seems working normal after that.

Expected Results:  
Run the script if required or not run it if not required.

default theme with Personas and other add-ons
(Reporter)

Comment 1

8 years ago
Created attachment 433268 [details]
unresponsive script nsBlokclistService.js:648
(Reporter)

Comment 2

8 years ago
There are 43 bugs filed about unresponsive script, but none is specific to nsBlokclistService.js:648 at startup.

I field it as critical because it happens every time at startup and is very annoying. 

Sure it is possible to choose "Don't ask me again", but still the problem is there.
Please see these threads:
https://support.mozilla.com/en-US/forum/1/565068
https://support.mozilla.com/en-US/forum/1/595817

As well as a google search of other topics with same error:
http://www.google.com/search?hl=en&q=nsblocklistservice+site%3Asupport.mozilla.com

I believe the issue stems from having old versions of Java installed. Starting with Firefox 3.6, Java 6 Update 10 and higher is required for Java to work.

See this page for that info:
http://www.java.com/en/download/faq/firefox_newplugin.xml

I've seen tons of users with like 10 old releases of Java still installed. I believe this causes conflicts. I'd uninstall all the older Javas via Add/Remove Programs in Windows Control panel if I were you, and have only the latest Java installed.

There is a program called JavaRa that tries to automatically remove all old Java versions and install the latest version, see here:
https://support.mozilla.com/forum/1/595817#threadId608043

Although the line error seems to vary for people. So far I've seen 648 & 651.
Summary: unresponsive script nsBlokclistService.js:648 at startup → unresponsive script nsBlocklistService.js:648 at startup
(Reporter)

Comment 5

8 years ago
I checked my Java version: Java 6 Update 18. No other version exists on this PC. I am sorry I am not one of the tons users you mentioned.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542695

Comment 7

8 years ago
I looked a this bug from 542695.  I also have Java 6 Update 18 and no other versions of Java.
You need to log in before you can comment on or make changes to this bug.