"Discover" does not match the "Discover Add-ons" title

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: tchung, Assigned: Unfocused)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta5+)

Details

(Whiteboard: [rewrite])

Attachments

(1 attachment)

Reporter

Description

9 years ago
"Discover" does not match the "Discover Add-ons" title. the other categories do match up accordingly. 

See screenshot

Repro:
1) install addons branch build: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6;
en-US; rv:1.9.3a3pre) Gecko/20100318 Minefield/3.7a3pre
2) open addons manager
3) Verify the "Discover" pane doesnt match the title which says "Discover Addons".  i would imagine they should sync like how the other panes/titles do.

Expected:
- Discover pane title matches

Actual:
- it doesnt.
Reporter

Comment 1

9 years ago
Reporter

Updated

9 years ago
Blocks: 550048
Whiteboard: [rewrite]
I'm recommending that Fligtar's page, as well as the category, remain entitled "Get Add-ons" rather than "Discovery."  The reasons for this are:

- "Get Add-ons" gives users some information about what they're looking at: it tells them that they're looking at a page that stores add-ons and that they can acquire add-ons through this page.  While it's true you can add add-ons through a search as well, "get add-ons" expresses simply that acquisition can happen on this page.

- "Get Add-ons" is different enough from the other categories to make the distinction between the singular acquisition page and the rest of the inventory pages.  An issue with the word "Discovery" in particular is that it sounds as though it could be an add-on category (I notice many add-ons have the word "discovery" in their title, for instance)

- "Get Add-ons" is the current name of this page's equivalent, and without a much better option I'd prefer not to change it

I'm CC'ing Fligtar, who has spearheaded the design of this page, to get his opinion
Keywords: uiwanted
Version: unspecified → Trunk
I'm fine with leaving it Get Add-ons, at least until we can discuss naming across the board. My ugly mock shouldn't have bugs filed against it quite yet :)
Find or Search would be more descriptive IMO.
We already have a Search pane, for local and AMO search. Having a separate "Find" pane would be confusing, IMO. Also, the "Get Add-ons"/"Discover" pane isn't about searching - more about discovering, learning, that type of thing.
(In reply to comment #5)
> We already have a Search pane, for local and AMO search. Having a separate
> "Find" pane would be confusing, IMO. Also, the "Get Add-ons"/"Discover" pane
> isn't about searching - more about discovering, learning, that type of thing.

This is basically the idea, Brian.  The added advantage of "Get Add-ons" over "Discover" is that it relates information to users: that add-ons are items that can be obtained.  The other problem with "Discover" is that it's more easily confused with different categories.  Many add-ons in AMO brand themselves as aiding in "discovery" - of new sites, deals, travel, etc.  The repetition of the word "Add-ons" in the Add-ons Manager places this category outside the others as one for acquiring add-ons, rather than storing them.
Duplicate of this bug: 565300
blocking2.0: --- → final+
Assignee: nobody → bmcbride
Needed by string freeze
blocking2.0: final+ → beta5+
Currently the wording is "Get Add-ons" - we'll be keeping that wording, for the reasons detailed in comment 6.

It changed from "Discover" sometime before the initial landing on trunk.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.