Status

()

Firefox
General
VERIFIED DUPLICATE of bug 484799
8 years ago
8 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ts])

(Reporter)

Description

8 years ago
From Ehsan:

* Rebasing our DLLs
When Windows tries to load a DLL, it first tries to map the DLL at
0x10000000.  If that doesn't work, the OS finds another space in the
address space big enough for the DLL, maps the DLL in that address,
and goes through something called the fixup phase, which means it
looks for places in the DLL code which have absolute addresses (like
absolute jmp's, and static objects) and modifies their addresses to
make them valid.

(Note: we might already do this)
(Reporter)

Updated

8 years ago
Whiteboard: [ts]
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 484799
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.