If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[SeaMonkey 2.1] mochitest-chrome: bug 530872 update ui tests time out

VERIFIED FIXED

Status

()

Toolkit
Application Update
--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: rstrong)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [test which aborts the suite])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Example:
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1269035790.1269038741.26592.gz&fulltext=1
Linux comm-central-trunk debug test mochitest-other on 2010/03/19 14:56:30

13839 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/update/test/chrome/test_0011_check_billboard_noLicense_noAddons.xul | Test timed out.
13998 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/update/test/chrome/test_0012_check_billboard_noAddons.xul | Test timed out.
14032 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/update/test/chrome/test_0021_check_noBillboard_noLicense_noAddons.xul | Test timed out.
14174 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/update/test/chrome/test_0022_check_noBillboard_noAddons.xul | Test timed out.
14175 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | 4 test timeouts, giving up.
14176 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | Skipping 36 remaining tests.
}
This is caused by the tests not taking into account the extensions installed by default in Seamonky... I'll rewrite the tests accordingly.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Summary: [SeaMonkey 2.1] Bug 530872 ("billboard") tests time out → [SeaMonkey 2.1] Bug 530872 update ui tests time out
Depends on: 553890
(Reporter)

Updated

8 years ago
Summary: [SeaMonkey 2.1] Bug 530872 update ui tests time out → [SeaMonkey 2.1] mochitest-other: bug 530872 update ui tests time out
(Reporter)

Updated

8 years ago
Summary: [SeaMonkey 2.1] mochitest-other: bug 530872 update ui tests time out → [SeaMonkey 2.1] mochitest-chrome: bug 530872 update ui tests time out
Created attachment 435122 [details] [diff] [review]
patch rev1

Took a break from reviews / Q1 work and knocked this out
Attachment #435122 - Flags: review?(dolske)
Created attachment 435124 [details] [diff] [review]
patch rev1 - forgot to qrefresh
Attachment #435122 - Attachment is obsolete: true
Attachment #435124 - Flags: review?(dolske)
Attachment #435122 - Flags: review?(dolske)
Comment on attachment 435124 [details] [diff] [review]
patch rev1 - forgot to qrefresh

Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/e0321787e483
Attachment #435124 - Flags: review?(dolske) → review+
Flags: in-testsuite+
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 5

8 years ago
Yay, thanks, we actually have passing mochitest-chrome on Linux and Mac now (the Windows failures are different things, and a leak on Mac is still there, but probably unrelated as well, existed also when this still failed).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.