Closed Bug 553874 Opened 12 years ago Closed 12 years ago

Some reftest runs on windows hit "rm: cannot remove directory `build/reftest/tests/modules/libpr0n/test/reftest/icon/win': Directory not empty"

Categories

(Core :: ImageLib, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.9.3a4

People

(Reporter: jruderman, Assigned: neil)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox
/1269184997.1269185525.26168.gz
WINNT 5.2 mozilla-central opt test reftest on 2010/03/21 08:23:17
s: mw32-ix-slave09

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269172654.1269174500.26044.gz
WINNT 5.2 mozilla-central debug test reftest on 2010/03/21 04:57:34
s: win32-slave35
Blocks: 438871
Whiteboard: [orange]
Fixed both slaves by deleting troublesome directories with windows explorer.
Assignee: nobody → nrthomas
Status: NEW → RESOLVED
Closed: 12 years ago
Priority: -- → P2
Resolution: --- → FIXED
Reopening, this is not the circular dependency problem we sometimes hit on NTFS. philor thinks it might be a regression from bug 415761.
Blocks: 415761
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 553951
Summary: Windows mw32-ix-slave09 "rm: cannot remove directory `build/reftest/tests/modules/libpr0n/test/reftest/icon/win': Directory not empty" → Some reftest runson windows hit "rm: cannot remove directory `build/reftest/tests/modules/libpr0n/test/reftest/icon/win': Directory not empty"
Attached patch Possible patchSplinter Review
Over to Neil.
Assignee: nrthomas → neil
Component: Release Engineering → ImageLib
Priority: P2 → --
Product: mozilla.org → Core
QA Contact: release → imagelib
Summary: Some reftest runson windows hit "rm: cannot remove directory `build/reftest/tests/modules/libpr0n/test/reftest/icon/win': Directory not empty" → Some reftest runs on windows hit "rm: cannot remove directory `build/reftest/tests/modules/libpr0n/test/reftest/icon/win': Directory not empty"
Version: other → Trunk
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269218605.1269219151.8784.gz
WINNT 5.2 mozilla-central opt test reftest on 2010/03/21 17:43:25
s: win32-slave26
(In reply to comment #7)
Fixed this machine.
Landed just the chmod part in http://hg.mozilla.org/mozilla-central/rev/e26e8db7e8e7 to see if that would be enough, since "newly created executable can't be removed on Windows" sounded awfully familiar to me from having configure constantly but randomly fail to remove test executables.
And landed the rest of it in http://hg.mozilla.org/mozilla-central/rev/b73731682923 since just the chmod wasn't enough.
Has been green since then, and I've cleaned up any slaves that did an opt or debug reftest since the original landing. Lets be bold an call this fixed.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
Target Milestone: --- → mozilla1.9.3a4
SeaMonkey needs cleanup too!
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.