Edit mode toolbar should be visible by default.

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: braden, Assigned: cmanske)

Tracking

({regression})

Trunk
mozilla0.9.4
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Edit mode toolbar should be visible by default.
(Reporter)

Updated

19 years ago
Keywords: regression

Comment 1

19 years ago
agreed.  I just noticed the older discussion about this in the newsgroups; I 
would have commented there earlier had I seen it.

If this is going to be anything like a WYSIWYG editor, these tabs are going to 
be used a lot; who wants to use the View menu?  I don't understand why the edit 
mode toolbar is off by default whereas, say, the sidebar is on by default (who 
uses the sidebar in Composer more than they switch between views?)
FWIW, I'd go for it activated by default.  I think it is something that would be 
used much.  Some users may never come across it otherwise.

Comment 3

19 years ago
Personally, I don't switch modes very often and I prefer to have the extra 2 
lines for editing rather than being occupied by the toolbar.

Novices might be confused by the subtle differences in the modes.  Advanced users 
won't be.  Advanced users know to (or are much more likely to find) turn on the 
Toolbar in the View menu.  Once the toolbar is shown, the the toolbar will remain 
until the user turns it off.

Why is this considered to be a regression?
Target Milestone: --- → Future
Quoting myself:
"In some cases UI elements that are only semi-useful or redundant are 
turned on by default. In this case, however, a useful part of the UI is 
off by default."

Comment 5

19 years ago
If the Edit Mode toolbar is being hidden by default to save ~2 lines worth of 
space to type, then surely the sidebar needs to be hidden by default to save 
much more space.
(Reporter)

Comment 6

19 years ago
brade: It's a regression because the toolbar used to be on by default. That is,
this was "working" before, now it's not.

Comment 7

18 years ago
setting to accept to get it off the new radar
Status: NEW → ASSIGNED

Comment 8

18 years ago
-->cmanske
Assignee: beppe → cmanske
Status: ASSIGNED → NEW
(Assignee)

Comment 9

18 years ago
It is.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 10

18 years ago
verify
Status: RESOLVED → VERIFIED
Target Milestone: Future → mozilla0.9.4
You need to log in before you can comment on or make changes to this bug.