Animated GIFs run too quickly

RESOLVED DUPLICATE of bug 232769

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 232769
8 years ago
8 years ago

People

(Reporter: Kevin Israel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Animated GIFs, in Firefox 3.6, run about 2.4 times as fast as in Internet Explorer 8 (and Safari, etc.).

Reproducible: Always

Steps to Reproduce:
1. Open the above URL of a kaleidoscope animation in Firefox. You can use http://commons.wikimedia.org/wiki/File:Bouncywikilogo.gif as an additional test image.
2. Click on the image for a direct link.
3. Repeat steps 1 and 2 in another browser such as IE or Safari.
4. Install Greasemonkey and this user script: http://userscripts.org/scripts/show/72090 that slows down animated GIFs, multiplying all delays by a factor of 2.4.
5. Repeat step 1, observing the slowdown. (The script does not apply the slowdown to direct-linked images.)
Actual Results:  
The animation is noticeably faster in steps 1 and 2 than in steps 3 and 5. The 2.4x slowdown applied in step 5 causes the frame rate to approximately match that of Internet Explorer and Safari (which are about equal).

Expected Results:  
The animation should run at the same speed in all three browsers.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 232769
You need to log in before you can comment on or make changes to this bug.