Last Comment Bug 554169 - Jetpacks get disabled on recent Minefield nightlies
: Jetpacks get disabled on recent Minefield nightlies
Status: RESOLVED FIXED
: dogfood, regression
Product: Mozilla Labs
Classification: Other
Component: Jetpack Prototype (show other bugs)
: Trunk
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-22 15:02 PDT by :Ehsan Akhgari
Modified: 2010-03-31 23:46 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description :Ehsan Akhgari 2010-03-22 15:02:21 PDT
mak had also seen this issue.  I'm noticing that jetpacks get disabled on recent Minefield nightlies with Jetpack 0.8.1.  This should have happened some time in the past week.

What happens is Jetpacks just stop working after some time.  The workaround is to go to about:jetpack, uninstall them, reinstall them, and they will start working for a some limited time (a few minutes), and then they will stop working again.

This is fairly serious, since it will prevent me (and possibly other developers) from dogfooding recent nightlies, since we have a few jetpacks on which we rely for daily development.  I'm considering stepping down from nightlies, and that feels weird, since it'd be the first time in a couple of years for me not to run a nightly as my daily browser.  :-(
Comment 1 :Ehsan Akhgari 2010-03-23 16:59:11 PDT
One other thing I've noticed is that if a jetpack has been working on a certain tab, it will continue to work on that tab, but it might be disabled in new tabs.

I'm running different nightly versions against my main profile to try to determine a regression range for this.
Comment 2 :Ehsan Akhgari 2010-03-25 17:32:04 PDT
Here's the regression range:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=050887c64183&tochange=16a974dd72e1

I'll probably bisect at this point.
Comment 3 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2010-03-26 14:16:17 PDT
90% sure it's http://hg.mozilla.org/mozilla-central/rev/8ca8630b0c88, which is fixed on hg (but not released) by http://hg.mozilla.org/labs/jetpack/rev/598c88bb84bb. Moving the tabs caused a lot of problems with various extensions which were attaching "TabOpen", "TabSelect", "TabClose" event listeners to the tabbrowser.
Comment 4 :Ehsan Akhgari 2010-03-26 16:23:37 PDT
Yes, in my testings, you're right.  It's a regression from bug 347930, and using the latest jetpack trunk fixes this problem.  Do we plan on shipping the latest tip as a minor update (0.8.2)?  I think we should.

Otherwise I'll just publish the latest builds on some server myself, I guess...
Comment 5 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2010-03-31 23:46:02 PDT
Jetpack Prototype 0.8.2 was release so this is fixed. Yay!
http://hg.mozilla.org/labs/jetpack/rev/598c88bb84bb

Note You need to log in before you can comment on or make changes to this bug.