I would like to install an extension without restarting firefox.

RESOLVED DUPLICATE of bug 256509

Status

()

Firefox
Extension Compatibility
--
enhancement
RESOLVED DUPLICATE of bug 256509
8 years ago
8 years ago

People

(Reporter: aicitman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

As every firefox user knows, there's one feature they don't like. The restart button. Which pops up every time you install an extension.
I don't think that there's any reason why every add needs a restart, why a disable requires a restart, and why a update of an add on requires a restart.
Obviously, the add on needs to be designed for it, but for most addons that shouldn't be a big deal. Just run the startup or init code, and it's set to go.

Reproducible: Always

Steps to Reproduce:
1.click on add-on page "add to firefox"
2.wait till it finishes downloading
3.restart button pops up on top
Actual Results:  
The restart button will need to be pressed, thereby resulting in up to 30 seconds wasted (the more add-ons you have, the longer it takes).

Expected Results:  
No restart should be available, and should just install the extension and start running it right away.

I think that if an extension needs a restart, it should have an option to request a restart. But most extensions shouldn't need it.

Comment 1

8 years ago
A much requested feature. Please search before posting in the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 256509
You need to log in before you can comment on or make changes to this bug.