Closed Bug 554193 Opened 11 years ago Closed 11 years ago

mochitest-other failed with "browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]"

Categories

(Toolkit :: Places, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: cjones, Assigned: mak)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269297885.1269299450.29179.gz
Linux mozilla-central opt test mochitest-other on 2010/03/22 15:44:45  
s: moz2-linux-slave10

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | automation.py | application timed out after 330 seconds with no output

This error message doesn't make any sense to me.  The test failure is off of http://hg.mozilla.org/mozilla-central/rev/b4d603fb501d, which is miles away from places, so I suspect this might be a new rando-orange candidate.
Whiteboard: [orange]
hm, linux, makes me think to various random we have with the focus manager :(
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269442835.1269444103.28593.gz
Linux mozilla-central opt test mochitest-other on 2010/03/24 08:00:35
s: moz2-linux-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269445041.1269446570.4781.gz
Linux mozilla-central opt test mochitest-other on 2010/03/24 08:37:21
s: moz2-linux-slave05
this  is due to a change that has been pushed in february, the problem is that we should waitForFocus twice, once before clicking the link, and once before moving to the next test. The change involved changing focuus between library and browser window when clicking on library's links.

i probably have a fix locally in another patch.
Blocks: 559354
Attached patch patch v1.0Splinter Review
so the problem is that when we give focus to Library we should wait for it to have focus, then fire the middle click event, then wait for browser to get focus, and so on. We run too much.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #439115 - Flags: review?(dietrich)
Attachment #439115 - Flags: review?(dietrich) → review+
i also enlarged the timeout by 2, looks like since it has to wait focus, it's taking more time.  I just hope Linux won't be picky, that change from february should have gone to its own test, not change this one since it was so much focus related :(
http://hg.mozilla.org/mozilla-central/rev/8a4ad4811877
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.