[k] Paginator throws UnicodeEncodeError on non-ascii (?) characters

VERIFIED FIXED in 2.0

Status

support.mozilla.org
General
P1
blocker
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: paulc, Assigned: jsocol)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
The paginator doesn't seem to like non-ascii characters, e.g. urls like:
/ru/search?w=3&q=%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0
/fr/search?w=3&q=Gloss%C3%A1rio
(Reporter)

Comment 1

8 years ago
We should be using flatqs for building the URL anyway, in which case this problem can be fixed as part of flatqs.

I've found these resources that should help:
http://stackoverflow.com/questions/804336/best-way-to-convert-a-unicode-url-to-ascii-utf-8-percent-escaped-in-python
http://stackoverflow.com/questions/1077564/python-unicode-unicodeencodeerror
(Assignee)

Updated

8 years ago
Assignee: nobody → james
Severity: normal → major
Priority: -- → P1
(Assignee)

Updated

8 years ago
Duplicate of this bug: 557453
(Assignee)

Comment 3

8 years ago
I've been working on this but every query with an accent guaranteed to return more than a page of results runs into bug 554210.
Depends on: 554210
(Assignee)

Comment 4

8 years ago
I did push a new version of flatqs that should handle UTF-8 a little better:

http://github.com/jsocol/flatqs/commit/fc0b5d89cc78b894eaf73c48dde81d0f197c7a15
(Assignee)

Updated

8 years ago
Severity: major → blocker
(Assignee)

Comment 5

8 years ago
Pull requests sent for r? and f?

http://github.com/jsocol/kitsune/commit/5bd11d7fb9d07088d9351288cafafd76880e28f1
(Assignee)

Comment 6

8 years ago
Pull requests sent for r? and f? (again)

http://github.com/jsocol/kitsune/commit/862128cb64793c2db9b0641bf39dba32972b921e
(Reporter)

Comment 7

8 years ago
This looks good to go. r+ at latest commit:
http://github.com/jsocol/kitsune/commit/f2ddcafb6de08bef55760993be8cfa5630f5c8b2
(Assignee)

Comment 8

8 years ago
Wooot!

http://github.com/jsocol/kitsune/commit/240c9469ee4f5928b2ca1b85e7b15f36229ed778

Build #28.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
I'm getting 500 Internal Server Errors with this:

http://support-stage-new.mozilla.com/ru/search?w=3&q=%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0

Separate bug, or this?
Verified FIXED on http://support-stage-new.mozilla.com/ru/search?w=3&q=%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.