Last Comment Bug 55456 - table frames should honor the ascent information (vertical-align:baseline for nested tables)
: table frames should honor the ascent information (vertical-align:baseline for...
Status: RESOLVED WORKSFORME
[CSS1-5.4.4]
: css1, testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: All All
: P3 normal with 1 vote (vote)
: Future
Assigned To: layout.tables
: Amarendra Hanumanula
:
Mentors:
: 160325 181082 183584 206430 (view as bug list)
Depends on: 51684 64763
Blocks: 146146
  Show dependency treegraph
 
Reported: 2000-10-05 22:31 PDT by Hixie (not reading bugmail)
Modified: 2014-10-11 12:41 PDT (History)
15 users (show)
bernd_mozilla: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase with nested tables (1.51 KB, text/html)
2000-10-12 16:47 PDT, Christine Hoffman
no flags Details
modified testcase to expose the problem (1.73 KB, text/html)
2000-10-12 23:44 PDT, rbs
no flags Details
Testcase from bug 146146 which is a dupe of this one (1.20 KB, text/html)
2002-05-23 05:21 PDT, Erich 'Ricky' Iseli
no flags Details
revised testcase (1.52 KB, text/html)
2009-04-21 22:59 PDT, Bernd
no flags Details

Description Hixie (not reading bugmail) 2000-10-05 22:31:21 PDT
In bug 10207, rbs wrote:
> The remainig case is that of <td> <table> ... </table> </td>. This other 
> special case (but frequent case) won't work because the table code is not yet 
> honoring the ascent. Hence the table code still needs some further tuning so 
> that it returns its ascent (i.e., the ascent of its first row).
> 
> For things to work right, all frames should honor the ascent information.
> Currently, <table> is the remaining HTML frame that is not honoring that 
> information, and 
>    <td valign="baseline"> <table>...</table> </td>
> doesn't mean anything.
> 
> So the table code should return the ascent of its first row.
Comment 1 Hixie (not reading bugmail) 2000-10-05 22:34:21 PDT
We need some test cases for checking vertical-align of nested tables. Things to
check would be three-deep nested tables, colspan and rowspan, interaction with
CSS anonymous tables (e.g. nested display:table-cell elements), etc.
Comment 2 rbs 2000-10-08 12:43:44 PDT
With the current setup, the way to go about fixing this bug will involve
caching the table-row's ascent, and the table's ascent and provide means 
to access/manipulate the information. I suggest we keep this bug on hold
as we could get the information differently from nsArea (bug 51684).
Comment 3 Christine Hoffman 2000-10-12 16:46:23 PDT
Don't know exactly what this bug is, but I am attaching a file with three-deep 
nested tables, all with vertical-align: baseline values given to TD. Works in 
10/12 build on Win 98
Comment 4 Christine Hoffman 2000-10-12 16:47:55 PDT
Created attachment 16940 [details]
testcase with nested tables
Comment 5 rbs 2000-10-12 23:44:31 PDT
Created attachment 16981 [details]
modified testcase to expose the problem
Comment 6 rbs 2000-10-12 23:46:57 PDT
The modified testcase was obtained by substituting:

<td style="font-size: 30pt">Comparison cell</td>

to:

<td><table border="0"><tr><td style="font-size: 30pt">Comparison 
cell</td></tr></table></td>
Comment 7 Hixie (not reading bugmail) 2000-12-11 16:18:15 PST
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Comment 8 Hixie (not reading bugmail) 2001-02-12 16:28:09 PST
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
Comment 9 rbs 2001-04-26 00:41:58 PDT
Adopting bug 64763 "Switch from nsRect mRect to nsArea in the frame model" would 
greatly help this bug.
Comment 10 Kevin McCluskey (gone) 2001-10-04 16:33:04 PDT
Build reassigning Buster's bugs to Marc.
Comment 11 rbs 2002-05-22 21:55:58 PDT
*** Bug 146146 has been marked as a duplicate of this bug. ***
Comment 12 Erich 'Ricky' Iseli 2002-05-23 05:21:31 PDT
Created attachment 84747 [details]
Testcase from bug 146146 which is a dupe of this one
Comment 13 Boris Zbarsky [:bz] (still a bit busy) 2002-11-20 08:42:37 PST
*** Bug 181082 has been marked as a duplicate of this bug. ***
Comment 14 Hixie (not reading bugmail) 2002-11-20 22:40:37 PST
->Tables
Comment 15 Boris Zbarsky [:bz] (still a bit busy) 2002-12-04 15:03:00 PST
*** Bug 183584 has been marked as a duplicate of this bug. ***
Comment 16 Daniel Wang 2003-04-03 21:18:47 PST
this bug and bug 54979 have similar dupes. depending on, blocking?
Comment 17 Boris Zbarsky [:bz] (still a bit busy) 2003-04-29 11:03:37 PDT
*** Bug 160325 has been marked as a duplicate of this bug. ***
Comment 18 Boris Zbarsky [:bz] (still a bit busy) 2003-05-20 08:49:36 PDT
*** Bug 206430 has been marked as a duplicate of this bug. ***
Comment 19 Mats Palmgren (:mats) 2003-11-01 15:27:13 PST
*** Bug 224415 has been marked as a duplicate of this bug. ***
Comment 20 David Baron :dbaron: ⌚️UTC-10 2003-11-01 16:52:59 PST
*** Bug 146146 has been marked as a duplicate of this bug. ***
Comment 21 David Baron :dbaron: ⌚️UTC-10 2003-11-01 16:53:29 PST
*** Bug 224415 has been marked as a duplicate of this bug. ***
Comment 22 Bernd 2009-04-21 22:59:43 PDT
Created attachment 374016 [details]
revised testcase

both attachment 16940 [details]: testcase with nested tables
and attachment 16981 [details]: modified testcase to expose the problem

show on top td {vertical-align: baseline}

this arises from the following markup:

<style="text/css">
td { vertical-align: baseline }
</style

which does not make this a style block, so the tested property does not apply.

This is WFM
Comment 23 David Baron :dbaron: ⌚️UTC-10 2009-04-21 23:16:36 PDT
I suspect I fixed this around when I was implementing inline-block and inline-table.
Comment 24 David Baron :dbaron: ⌚️UTC-10 2009-04-21 23:50:22 PDT
In particular, I was thinking of bug 367332, although it might have been fixed earlier.
Comment 25 Bernd 2009-04-22 11:45:28 PDT
certainly earlier, man all the years I was fooled by the colored testcase,

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 SeaMonkey/1.1a

Note You need to log in before you can comment on or make changes to this bug.