Worng Content is displayed in iframe if you reload a page while the page is still loading

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: jkluemper, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 GTB6 (.NET CLR 3.5.30729)

If you press F5 while a page is still loading, you may get content of an iframe
from the last page in the reloaded page. This happens if the reloaded page has
less iframes than the last page. In the example we can reproduce it with iframes
but we also saw it with other external? content.


Reproducible: Sometimes

Steps to Reproduce:
open http://www.raikosoft.com/reloadbug/main.php
you can download the page source here:
http://www.raikosoft.com/reloadbug/reloadbug.zip

The page uses 4 seconds sleeps to show the behavior better.
On the page there are two iframes:
one shows the text "Top" in a red iframe
the other shows the text "Bottom" in a blue iframe.
The blue iframe is shown always. The red iframe is shown by random.
   
1. load the page http://www.raikosoft.com/reloadbug/main.php until you see both
   iframes.
2. press F5 
3. press F5 again within 2 seconds (while the page is still loading)
4. repeat step 2 and 3 until you see the red "Top" iframe under the hr line
Actual Results:  
The content of the red "Top" iframe is shown instead of the blue "Bottom" iframe.


We think this is not an iframe problem but a problem with content which is loaded
in background. If you load a page while the current page is still loading,
perhaps the background threads? are not canceled. So the content of the last page is shown in the new page.
You can also reproduce the bug with the forward/backward buttons.

Feel free to contact us for additional infos.

Comment 1

8 years ago
I can confirm this bug. We have been seeing this on our website for 1-2 years and still happens on the most current version of Firefox. The problem usually happens if a page contains several iframes (usually ads). On subsequent pageviews or refreshes, the content of an iframe in the previous page can show up in a random iframe on the current page.

I always assumed that this was such an obvious bug that it would get discovered and solved soon, but apparently it still exists and this particular bug is not even confirmed.

Comment 2

8 years ago
I can confirm the bug too. In our website we are experiencing the issue time to time. Our solution was to give up on some of the iframes on the page since the early versions of firefox 3.x.

Comment 3

8 years ago
I can confirm this bug, its happening on my website too. Im surprised about this since in all other browsers this not seems to happen.

Updated

7 years ago
Version: unspecified → 3.6 Branch
Reporter, Firefox 4.0.1 has been released, and it features significant improvements over previous releases. Can you please update to Firefox 4.0.1 or later, and retest your bug? Please also create a fresh profile (
http://support.mozilla.com/kb/Managing+profiles), update your plugins (Flash, Java, Quicktime, Reader, etc) and update your graphics driver and Operating system to the latest versions available. 

If you still continue to see this issue, please comment. If you do not, please close this bug as RESOLVED > WORKSFORME

filter: prefirefox4uncobugs

Comment 5

7 years ago
Unable to verify on Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110625 Firefox/7.0a1 ID:20110625030743

Are you still experiencing this issue with the latest version of Firefox 5? Does the issue occur with the latest nightly? http://nightly.mozilla.org/

Comment 6

7 years ago
Closing bug as WFM - if you are still experiencing this issue or have more information to provide feel free to post back here and we can re-open the bug. You can also get assistance by visiting the Firefox help site -> http://support.mozilla.com/en-US/kb/Ask+a+question
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.