enabling AVMFEATURE_INTERIOR_POINTERS=1 will fail to compile

RESOLVED FIXED in Q3 11 - Serrano

Status

P4
normal
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: edwsmith, Assigned: lhansen)

Tracking

unspecified
Q3 11 - Serrano
Bug Flags:
flashplayer-bug +

Details

(Whiteboard: Has patch)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Due to misspelling kHasInteriorPointers in this code in GC-inlines.h

 REALLY_INLINE GCWorkItem::GCWorkItem(const void *p, uint32_t s, GCWorkItemType workItemType)
     : ptr(p)
 #ifdef MMGC_INTERIOR_PTRS
     , _size(s | uint32_t(kHasInteriorPointers) | uint32_t(workItemType))
 #else
     , _size(s | uint32_t(workItemType))
 #endif

the code probably isn't well tested.

possible fixes:
1. fix the misspelling and hope for the best.
2. remove the feature entirely, less configuration surface to worry about.
(Reporter)

Comment 1

9 years ago
Lars's comments in bug 541338 make a case for keeping the feature ifdef, but it was a while ago and the facts on the ground might have changed since then.
Priority: -- → P4
Target Milestone: --- → flash10.2
(Assignee)

Updated

9 years ago
Assignee: nobody → lhansen
(Assignee)

Comment 2

9 years ago
Created attachment 437601 [details] [diff] [review]
Obvious patch
Attachment #437601 - Flags: review?(fklockii)
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
Whiteboard: Has patch
(Assignee)

Comment 3

9 years ago
(In reply to comment #1)
> Lars's comments in bug 541338 make a case for keeping the feature ifdef, but it
> was a while ago and the facts on the ground might have changed since then.

We should keep this as a debugging option for the time being, it is known to be useful when there are strange GC bugs.  There isn't much of a cpu cost to the feature, but it increases the chance of false retention of storage.  Once we move more in the direction of exact marking we should probably remove the feature.  I've lobbied in bug #557629 that we should demote it to a tweak.
Comment on attachment 437601 [details] [diff] [review]
Obvious patch

Confirmed that patch fixes compilation with ../configure.py --enable-interior-pointers
Attachment #437601 - Flags: review?(fklockii) → review+
(Assignee)

Comment 5

9 years ago
tamarin-redux changeset:   4350:b4aa6a0f4c9a
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

8 years ago
Flags: flashplayer-bug+
You need to log in before you can comment on or make changes to this bug.